CCIE.pl

site 4 CCIE wannabies
It is currently 23 Jan 2017, 15:39

All times are UTC+01:00




Post new topic  Reply to topic  [ 8 posts ] 
Author Message
Post #1 Posted: 19 Dec 2016, 16:40 
Offline
wannabe
wannabe

Joined: 07 Nov 2009, 17:36
Posts: 62
Próbuję zestawić tunel MPLS L2VPN na łączu, gdzie switch (non-cisco) filtruje multicasty.
O ile z OSPFem nie ma problemu -> ip ospf non-broadcast oraz statycznie ustawiony sąsiad, o tyle z LDP nie jest już tak prosto.
Tak, wiem, są targeted sessions, ale jeżeli bezpośredni sąsiedzi nie widzą swoich ogłoszeń multicastowych 224.0.0.2, to tunel się nie zestawia, mimo że sesja targeted stoi.
Co ciekawe, gdy między routerami zestawię tunel GRE, w którym puszczę tylko OSPF i LDP, to oba te protokoły spokojnie sobie sąsiadów wykrywają, ale nadal ścieżka dla tunelu L2VPN jest niedostępna.

Oczywiście, że najprościej byłoby wyłączyć filtrowanie multicastów, jednak jest to z przyczyn polityki bezpieczeństwa niemożliwe.
Cel zestawienia samego tunelu, to także próba obejścia innych problemów, których przyczyną jest polityka i po części techniczne rozwiązanie w nieciscowym switchu, jak np limitu na adresy MAC.
Same filtry multicastowe czy limit na adresy MAC jak najbardziej są potrzebne i mają sens, niestety można je konfigurować tylko dla całej karty liniowej, stąd szukam rozwiązań - wyjątków, by nie obniżać bezpieczeństwa dla całej grupy klientów.


Top
   
Post #2 Posted: 19 Dec 2016, 18:17 
Offline
CCIE/CCDE
CCIE/CCDE
User avatar

Joined: 08 Mar 2004, 12:17
Posts: 2283
Location: Wawa
qrczak wrote:
O ile z OSPFem nie ma problemu -> ip ospf non-broadcast oraz statycznie ustawiony sąsiad, o tyle z LDP nie jest już tak prosto.
Tak, wiem, są targeted sessions, ale jeżeli bezpośredni sąsiedzi nie widzą swoich ogłoszeń multicastowych 224.0.0.2, to tunel się nie zestawia, mimo że sesja targeted stoi.

Jeżeli sesja targeted stoi, to wystarczy. Nie potrzebujesz mcastu. Etykiety powinny być wymienione. Pytanie, czy sesja targeted faktycznie jest up. Zestaw sesję między mpls router-id, rozgłoś adresy związane z router-id do IGP lub static.

BTW, można też zamiast LDP użyć BGP + send-label. Ale to tak w ramach ciekawostki.


Top
   
Post #3 Posted: 19 Dec 2016, 21:06 
Offline
wannabe
wannabe

Joined: 07 Nov 2009, 17:36
Posts: 62
No, niestety nie działa tak, jak mówisz. Ale dla uporządkowania konfigi i outputy :)
Dwa routery połączone ze sobą przez switcha, na którym opcjonalnie dla vlanu 4052 włączam i wyłączam multicast filtering.
Konfiguracja poza IP niemalże lustrzana, więc tylko jeden wydruk:
Code:
Router#sh run
Building configuration...

Current configuration : 2217 bytes
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
ethernet lmi ce
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
mpls label protocol ldp
!
!
vtp mode transparent
!
!
vlan 10,20
!
interface Loopback2
 ip address 10.201.0.2 255.255.255.255
!
interface GigabitEthernet0
 description LAN
 switchport access vlan 20
 no ip address
 no cdp enable
!
! (...)
interface GigabitEthernet8
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet8.4052
 encapsulation dot1Q 4052
 ip address 10.200.0.2 255.255.255.0
 ip ospf message-digest-key 1 md5 7 0835495D1D
 ip ospf network non-broadcast
 ip ospf dead-interval 40
 ip ospf hello-interval 10
 mpls ip
!
interface Vlan1
 no ip address
!
interface Vlan20
 no ip address
 xconnect 10.201.0.1 20 encapsulation mpls
!
router ospf 2
 network 10.200.0.0 0.0.0.255 area 2
 network 10.201.0.2 0.0.0.0 area 2
!
router bgp 65102
 bgp log-neighbor-changes
 neighbor 10.201.0.1 remote-as 65102
 neighbor 10.201.0.1 update-source Loopback2
 !
 address-family ipv4
  network 10.201.0.2 mask 255.255.255.255
  neighbor 10.201.0.1 activate
 exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
mpls ldp router-id Loopback2 force
!
control-plane
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 login
 transport input none
!
scheduler allocate 20000 1000
!
end


Na chwilę obecną mam więc wyłączonego OSPFa.

Code:
Router#sh mpls ldp neighbor
Router#sh xc al
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
DN pri   ac Vl20:20(Eth VLAN)            DN mpls 10.201.0.1:20                DN
Router#


Uruchamiam ręcznie sąsiada OSPF:
Code:
Router(config)#router ospf 2
Router(config-router)#neighbor 10.200.0.1


Co skutkuje już sesją OSPF, BGP i LDP:
Code:
*Dec 19 19:33:56.203: %OSPF-5-ADJCHG: Process 2, Nbr 10.201.0.1 on GigabitEthernet8.4052 from LOADING to FULL, Loading Done
*Dec 19 19:34:15.271: %BGP-5-NBR_RESET: Neighbor 10.201.0.1 active reset (BGP Notification sent)
*Dec 19 19:34:15.271: %BGP-5-ADJCHANGE: neighbor 10.201.0.1 Up
*Dec 19 19:34:18.227: %LDP-5-NBRCHG: LDP Neighbor 10.201.0.1:0 (1) is UP


Do tego momentu na switchu między tymi routerami mam włączone filtrowanie multicastu.
Co ciekawe, mimo że nie konfigurowałem sesji unicast targeted, to już się ona zestawiła:

Code:
Router#sh mpls ldp nei
    Peer LDP Ident: 10.201.0.1:0; Local LDP Ident 10.201.0.2:0
        TCP connection: 10.201.0.1.646 - 10.201.0.2.11439
        State: Oper; Msgs sent/rcvd: 11/16; Downstream
        Up time: 00:02:52
        LDP discovery sources:
          Targeted Hello 10.201.0.2 -> 10.201.0.1, active, passive
        Addresses bound to peer LDP Ident:
          10.3.5.1        10.3.10.3       10.21.0.8       10.201.0.1
          10.200.0.1


L2VPN jednak nie widzi drugiej strony:
Code:
Router#sh xc all
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
DN pri   ac Vl20:20(Eth VLAN)            UP mpls 10.201.0.1:20                DN
Router#

Router#sh mpls l2transport vc 20 detail
Local interface: Vl20 up, line protocol up, Eth VLAN 20 up
  Interworking type is Ethernet
  Destination address: 10.201.0.1, VC ID: 20, VC status: down
    Last error: MPLS dataplane reported a fault to the nexthop
    Output interface: none, imposed label stack {}
    Preferred path: not configured
    Default path: no route
    No adjacency
  Create time: 00:47:28, last status change time: 00:06:47
    Last label FSM state change time: 00:06:47
  Signaling protocol: LDP, peer 10.201.0.1:0 up
    Targeted Hello: 10.201.0.2(LDP Id) -> 10.201.0.1, LDP is UP
    Graceful restart: not configured and not enabled
    Non stop routing: not configured and not enabled
    Status TLV support (local/remote)   : enabled/supported
      LDP route watch                   : enabled
      Label/status state machine        : activating, LruRrdD
      Last local dataplane   status rcvd: DOWN(pw-tx-fault)
      Last BFD dataplane     status rcvd: Not sent
      Last BFD peer monitor  status rcvd: No fault
      Last local AC  circuit status rcvd: No fault
      Last local AC  circuit status sent: DOWN PW(rx/tx faults)
      Last local PW i/f circ status rcvd: No fault
      Last local LDP TLV     status sent: DOWN(pw-tx-fault)
      Last remote LDP TLV    status rcvd: DOWN(pw-tx-fault)
      Last remote LDP ADJ    status rcvd: No fault
    MPLS VC labels: local 16, remote 19
    Group ID: local n/a, remote 0
    MTU: local 1500, remote 1500
    Remote interface description:
  Sequencing: receive disabled, send disabled
  Control Word: On (configured: autosense)
  Dataplane:
    SSM segment/switch IDs: 0/4096 (used), PWID: 1
  VC statistics:
    transit packet totals: receive 0, send 0
    transit byte totals:   receive 0, send 0
    transit packet drops:  receive 0, seq error 0, send 0
Router#


W tym momencie wyłączam filtr multicastu i obserwuję debuggerem:
Code:
Router#debug mpls l2transport vc event
Router#
*Dec 19 19:48:12.071: AToM[10.201.0.1, 20]: Receive SSM dataplane up notification
*Dec 19 19:48:12.071: AToM[10.201.0.1, 20]: Evt dataplane up, activating->established
*Dec 19 19:48:12.071: AToM[10.201.0.1, 20]: . Dataplane activated
*Dec 19 19:48:12.071: AToM[10.201.0.1, 20]: ... No PW status SP info to report
*Dec 19 19:48:12.071: AToM[10.201.0.1, 20]: ... Send status update
*Dec 19 19:48:12.071: AToM[10.201.0.1, 20]: .... Not group switchover capable, cap C001525
*Dec 19 19:48:12.071: AToM[10.201.0.1, 20]: .... Circuit attributes, Send update:
*Dec 19 19:48:12.071: AToM[10.201.0.1, 20]: .....  Status: DOWN(pw-tx-fault) (0x20)
*Dec 19 19:48:12.071: AToM[10.201.0.1, 20]: ... NMS: VC oper state:  DOWN
*Dec 19 19:48:12.071: AToM[10.201.0.1, 20]: ... NMS:     err codes:    pw-tx-err
*Dec 19 19:48:12.071: AToM: 28 cumulative msgs handled. rc=0
*Dec 19 19:48:12.083: AToM[10.201.0.1, 20]: ...... No PW status SP info to report
*Dec 19 19:48:12.083: AToM[10.201.0.1, 20]: ...... Send status update
*Dec 19 19:48:12.083: AToM[10.201.0.1, 20]: ....... Not group switchover capable, cap C001525
*Dec 19 19:48:12.083: AToM[10.201.0.1, 20]: ....... Circuit attributes, Send update:
*Dec 19 19:48:12.083: AToM[10.201.0.1, 20]: ........  Status: UP (0x1)
*Dec 19 19:48:12.083: AToM[10.201.0.1, 20]: ...... NMS: VC oper state:  UP
*Dec 19 19:48:12.083: AToM[10.201.0.1, 20]: ...... SYSLOG: VC is UP
*Dec 19 19:48:12.083: AToM[10.201.0.1, 20]: ...... PW MIB: VC state is: UP
*Dec 19 19:48:12.083: AToM: 29 cumulative msgs handled. rc=0
Router#sh xc all
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP pri   ac Vl20:20(Eth VLAN)            UP mpls 10.201.0.1:20                UP
Router#


Włączam ponownie filtrowanie multicastów, konfiguruję tym razem ręcznie sesję targeted,
ale niczego to nie wnosi
Code:
Router(config)#mpls ldp discovery targeted-hello accept
Router(config)#mpls ldp neighbor 10.201.0.1 targeted

Router#sh xc all
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
DN pri   ac Vl20:20(Eth VLAN)            UP mpls 10.201.0.1:20                DN
Router#


Także... sesja targeted jest, ale tunel zestawia się tylko przy niewyfiltrowanym multicascie. Zupełnie, jakby tylko posiadanie bezposredniego sąsiedztwa, potwierdzonego wzajemnymi hello na 224.0.0.2 dawały prawo do użycia ewenętrznych etykiet, podczas gdy zewnętrzne jakos sobie jeszcze latają. A przecież sąsiad z targeted session jest directly connected...


Top
   
Post #4 Posted: 19 Dec 2016, 21:39 
Offline
CCIE
CCIE

Joined: 17 Dec 2010, 15:23
Posts: 721
Location: Dublin
qrczak wrote:
Code:

Router#sh mpls l2transport vc 20 detail
Local interface: Vl20 up, line protocol up, Eth VLAN 20 up
  Interworking type is Ethernet
  Destination address: 10.201.0.1, VC ID: 20, VC status: down
    Last error: MPLS dataplane reported a fault to the nexthop
    Output interface: none, imposed label stack {}
    Preferred path: not configured
    Default path: no route
    No adjacency



Tak na szybko jesli uzywasz xconnect to sesja jest zawsze target bo to jest P2P polaczenie. Dodatkowo oodpal sobie mpls na interfejsie interface GigabitEthernet8.4052 i tak samo po drugiej stronie. Nie zapomnij o mpls traget na obu urzadzeniach. Patrzac na output nie dostajesz VPN outer label od neighbor.

Jak sadze w twoim przypadku neighbor bedzie wysylal implic label, jesli chcesz to mozesz zmusic oba urzadzenia by wysylaly explict label. Wydaje mi sie, ze wtedy to powinno zadzialac.

Pozdro,


Top
   
Post #5 Posted: 20 Dec 2016, 00:11 
Offline
CCIE/CCDE
CCIE/CCDE
User avatar

Joined: 08 Mar 2004, 12:17
Posts: 2283
Location: Wawa
qrczak wrote:
No, niestety nie działa tak, jak mówisz. Ale dla uporządkowania konfigi i outputy :)

Do tego momentu na switchu między tymi routerami mam włączone filtrowanie multicastu.
Co ciekawe, mimo że nie konfigurowałem sesji unicast targeted, to już się ona zestawiła:

Działa, działa. Tylko skonfigurowałeś sobie jedną część MPLS, czyli wymianę etykiet usługowych. Potrzebujesz jeszcze sygnalizacji etykiety transportowej. Imp-null wystarczy, nie potrzeba exp-null. Jeżeli routery są bezpośrednio ze sobą połączone, to możesz oprzeć się na tej samej sesji targeted LDP. Uruchom MPLS na interfejsie pomiędzy urządzeniami.

U mnie w labie wygląda to tak:
Code:
R2#sh xc all
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP pri   ac Et0/1:3(Ethernet)            UP mpls 1.1.1.1:101                  UP

R2#sh mpls l2tr vc det
Local interface: Et0/1 up, line protocol up, Ethernet up
  Destination address: 1.1.1.1, VC ID: 101, VC status: up
    Output interface: Et0/0, imposed label stack {16}
    Preferred path: not configured 
    Default path: active
    Next hop: 172.16.0.1
  Create time: 00:21:37, last status change time: 00:20:15
    Last label FSM state change time: 00:19:14
  Signaling protocol: LDP, peer 1.1.1.1:0 up
    Targeted Hello: 2.2.2.2(LDP Id) -> 1.1.1.1, LDP is UP
    Graceful restart: not configured and not enabled
    Non stop routing: not configured and not enabled
    Status TLV support (local/remote)   : enabled/supported
      LDP route watch                   : enabled
      Label/status state machine        : established, LruRru
      Last local dataplane   status rcvd: No fault
      Last BFD dataplane     status rcvd: Not sent
      Last BFD peer monitor  status rcvd: No fault
      Last local AC  circuit status rcvd: No fault
      Last local AC  circuit status sent: No fault
      Last local PW i/f circ status rcvd: No fault
      Last local LDP TLV     status sent: No fault
      Last remote LDP TLV    status rcvd: No fault
      Last remote LDP ADJ    status rcvd: No fault
    MPLS VC labels: local 16, remote 16
    Group ID: local 0, remote 0
    MTU: local 1500, remote 1500
    Remote interface description:
  Sequencing: receive disabled, send disabled
  Control Word: On (configured: autosense)
  Dataplane:
    SSM segment/switch IDs: 4099/4096 (used), PWID: 1
  VC statistics:
    transit packet totals: receive 158, send 152
    transit byte totals:   receive 28766, send 30622
    transit packet drops:  receive 0, seq error 0, send 0

R2#sh mpls ldp disc
 Local LDP Identifier:
    2.2.2.2:0
    Discovery Sources:
    Interfaces:
   Ethernet0/0 (ldp): xmit/recv
       LDP Id: 1.1.1.1:0
    Targeted Hellos:
   2.2.2.2 -> 1.1.1.1 (ldp): active/passive, xmit/recv
       LDP Id: 1.1.1.1:0
      
R2#sh mpls for
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop   
Label      Label      or Tunnel Id     Switched      interface             
16         No Label   l2ckt(1)         23346         Et0/1      point2point
17         No Label   192.168.1.1/32   0             Et0/0      172.16.0.1 
18         Pop Label  1.1.1.1/32       0             Et0/0      172.16.0.1

R2#sh run | i mpls
mpls ldp neighbor 1.1.1.1 targeted ldp <<global config
 mpls ip <<int E0/0
 xconnect 1.1.1.1 101 encapsulation mpls <<int E0/1
mpls ldp router-id Loopback0 force <<global config


Top
   
Post #6 Posted: 20 Dec 2016, 07:21 
Offline
wannabe
wannabe

Joined: 07 Nov 2009, 17:36
Posts: 62
martino76 wrote:
Tak na szybko jesli uzywasz xconnect to sesja jest zawsze target bo to jest P2P polaczenie. Dodatkowo oodpal sobie mpls na interfejsie interface GigabitEthernet8.4052 i tak samo po drugiej stronie. Nie zapomnij o mpls traget na obu urzadzeniach. Patrzac na output nie dostajesz VPN outer label od neighbor.
gangrena wrote:
Działa, działa. Tylko skonfigurowałeś sobie jedną część MPLS, czyli wymianę etykiet usługowych. Potrzebujesz jeszcze sygnalizacji etykiety transportowej. Imp-null wystarczy, nie potrzeba exp-null. Jeżeli routery są bezpośrednio ze sobą połączone, to możesz oprzeć się na tej samej sesji targeted LDP. Uruchom MPLS na interfejsie pomiędzy urządzeniami.


Obaj napisaliście to samo, ale przecież mpls na tym interfejsie jest włączony po obu stronach:
Code:
interface GigabitEthernet8.4052
 encapsulation dot1Q 4052
 ip address 10.200.0.2 255.255.255.0
 ip ospf message-digest-key 1 md5 7 0835495D1D
 ip ospf network non-broadcast
 ip ospf dead-interval 40
 ip ospf hello-interval 10
 mpls ip
!

Oraz, jak wspominałem, wpisałem ręcznie sesję targeted, także po obu stronach:
Code:
mpls ldp neighbor 10.201.0.1 targeted
mpls ldp discovery targeted-hello accept
!

Wynik, niezmiennie:
Code:
Router#sh mpls ldp neighbor
    Peer LDP Ident: 10.201.0.1:0; Local LDP Ident 10.201.0.2:0
        TCP connection: 10.201.0.1.646 - 10.201.0.2.11439
        State: Oper; Msgs sent/rcvd: 735/736; Downstream
        Up time: 10:27:22
        LDP discovery sources:
          Targeted Hello 10.201.0.2 -> 10.201.0.1, active, passive
        Addresses bound to peer LDP Ident:
          10.3.5.1        10.3.10.3       10.21.0.8       10.201.0.1
          10.200.0.1
Router#sh mpls in
Router#sh mpls interfaces
Interface              IP            Tunnel   BGP Static Operational
GigabitEthernet8.4052  Yes (ldp)     No       No  No     Yes
Router#sh xc all
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
DN pri   ac Vl20:20(Eth VLAN)            UP mpls 10.201.0.1:20                DN
Router#


I gdy tylko wyłączam filtrowanie multicastu, pojawia się wskazane LDP discovery source:
Code:
Router#sh mpls ldp neighbor
    Peer LDP Ident: 10.201.0.1:0; Local LDP Ident 10.201.0.2:0
        TCP connection: 10.201.0.1.646 - 10.201.0.2.11439
        State: Oper; Msgs sent/rcvd: 738/739; Downstream
        Up time: 10:29:43
        LDP discovery sources:
          Targeted Hello 10.201.0.2 -> 10.201.0.1, active, passive
>>>          GigabitEthernet8.4052, Src IP addr: 10.200.0.1
        Addresses bound to peer LDP Ident:
          10.3.5.1        10.3.10.3       10.21.0.8       10.201.0.1
          10.200.0.1

I sesja xconnect idzie w górę:
Code:
Router#sh xc all
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP pri   ac Vl20:20(Eth VLAN)            UP mpls 10.201.0.1:20                UP
Router#

Pozostałe outputy:
Code:
Router#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C        10.200.0.0/24 is directly connected, GigabitEthernet8.4052
L        10.200.0.2/32 is directly connected, GigabitEthernet8.4052
O        10.201.0.1/32 [110/2] via 10.200.0.1, 10:37:44, GigabitEthernet8.4052
C        10.201.0.2/32 is directly connected, Loopback2
Router#sh bgp sum
BGP router identifier 10.201.0.2, local AS number 65102
BGP table version is 4, main routing table version 4
2 network entries using 288 bytes of memory
2 path entries using 160 bytes of memory
2/2 BGP path/bestpath attribute entries using 320 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 768 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.201.0.1      4        65102     709     710        4    0    0 10:39:56        1
Router#
Router#sh mpls ldp bi
  lib entry: 0.0.0.0/0, rev 10
        remote binding: lsr: 10.201.0.1:0, label: imp-null
  lib entry: 10.3.5.1/32, rev 9
        remote binding: lsr: 10.201.0.1:0, label: imp-null
  lib entry: 10.3.10.0/29, rev 7
        remote binding: lsr: 10.201.0.1:0, label: imp-null
  lib entry: 10.21.0.0/20, rev 8
        remote binding: lsr: 10.201.0.1:0, label: imp-null
  lib entry: 10.200.0.0/24, rev 2
        local binding:  label: imp-null
        remote binding: lsr: 10.201.0.1:0, label: imp-null
  lib entry: 10.201.0.1/32, rev 6
        local binding:  label: 17
        remote binding: lsr: 10.201.0.1:0, label: imp-null
  lib entry: 10.201.0.2/32, rev 4
        local binding:  label: imp-null
        remote binding: lsr: 10.201.0.1:0, label: 16
Router#



Top
   
Post #7 Posted: 20 Dec 2016, 11:22 
Offline
CCIE/CCDE
CCIE/CCDE
User avatar

Joined: 08 Mar 2004, 12:17
Posts: 2283
Location: Wawa
Jaki soft masz na routerach? Jeżeli masz możliwość reloadu, to zacząłbym od tego troubleshooting. Konfiguracja wydaje się być w porządku.


Top
   
Post #8 Posted: 20 Dec 2016, 12:03 
Offline
wannabe
wannabe

Joined: 07 Nov 2009, 17:36
Posts: 62
Robiłem już, bo to jest lab, więc mogę kombinować.
Code:
Router#sh ver
Cisco IOS Software, C800 Software (C800-UNIVERSALK9-M), Version 15.5(3)M, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2015 by Cisco Systems, Inc.
Compiled Wed 22-Jul-15 23:59 by prod_rel_team

ROM: System Bootstrap, Version 15.2(3r)XC, RELEASE SOFTWARE (fc1)

Router uptime is 16 hours, 7 minutes
System returned to ROM by reload at 18:51:15 UTC Mon Dec 19 2016
System image file is "flash:c800-universalk9-mz.SPA.155-3.M.bin"
Last reload type: Normal Reload
Last reload reason: Reload Command


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 8 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: Bing [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
This Website is not sponsored by, endorsed by or affiliated with Cisco Systems, Inc. Cisco, Cisco Systems, CCDA, CCNA, CCDP, CCNP, CCIE, CCSI, CCIP, the Cisco Systems logo and the CCIE logo are trademarks or registered trademarks of Cisco Systems, Inc. in the United States and certain other countries. Używamy informacji zapisanych za pomocą cookies i podobnych technologii m.in. w celach reklamowych i statystycznych oraz w celu dostosowania naszych serwisów do indywidualnych potrzeb użytkowników. Mogą też stosować je współpracujące z nami firmy. W programie służącym do obsługi internetu można zmienić ustawienia dotyczące cookies. Korzystanie z naszych serwisów internetowych bez zmiany ustawień dotyczących cookies oznacza, że będą one zapisane w pamięci urządzenia.



Powered by phpBB® Forum Software © phpBB Limited