CCIE.pl

site 4 CCIE wannabies
It is currently 18 Jan 2017, 08:59

All times are UTC+01:00




Post new topic  Reply to topic  [ 3 posts ] 
Author Message
Post #1 Posted: 02 Jul 2016, 20:38 
Offline
wannabe
wannabe

Joined: 05 Mar 2009, 16:17
Posts: 113
Cześć

Zamierzam stworzyć topologie, gdzie warstwa core dla DC zbudowana jest w oparciu o 2 Nexusy serii 9300 (9372PX) do których podpięte będą przełączniki ToR (Catalysty 3850).
Każdy przełącznik ToR będzie podpięty do obu Nexusów poprzez 4x10G, gdzie 2x10G idzie do pierwszego NX9300, a drugie 2x10G idzie do drugiego NX9300. Wszystkie 4 linki będa tworzyć jeden PortChannel z LACP + vPC po stronie Nexusów.
Pomiędzy Nexusami będzie Peer-Link 4x40G (PortChannel) oraz Peer-KeepaliveLink (poprzez porty MGMT).

Nexusy beda robic routing dla kilku VLAN'ów (inter-vlan routing + routing statyczny), gdzie oba Nexusy będą miały skonfigurowane HSRP na SVI z priorytetami 105 (master) i 100 (slave, drugi NX9300).
Routing statyczny do default-route'a do firewalli oraz kilka wpisów typu ip route 10.0.0.0/24 .... do maszyn VPN'owych. Na obu Nexusach beda analogiczne wpisy jako ze firewalle jaki maszyny VPN maja analogicznie do HSRP skonfigurowane VRRP.

I teraz pytanie za 100 punktow:

O ile wszystko powyzsze powinno dzialac, nie jestem pewny co do routingu statycznego.
Zarowno firewalle do Internetu jak i maszyny VPN sa wpiete do ToR'ow - czyli sa osiagalne przez vPC.
Czy nie ma tutaj jakis ograniczen z routingiem przez hosty za VPC ?

Soft na chwile obecna ktory mam na Nexusach to 7.0(3)I2(2e)

Kawalek konfiguracji:

Code:
feature interface-vlan
feature hsrp
feature lacp
feature vpc
!
vlan 2
vlan 3
!
spanning-tree vlan 1-10 priority 4096
vpc domain 1
  peer-switch
  role priority 4096 ! drugi Nexus ma 8192
  peer-keepalive destination 10.10.10.2 source 10.10.10.1 vrf management
  delay restore 360
  peer-gateway
  ip arp synchronize
!
interface Vlan2
  description Maszyny VM
  no shutdown
  ip address 10.0.0.1/24
  hsrp 2
    preempt
    priority 105
    ip 10.0.0.254
!
interface Vlan3
  description Firewalls
  no shutdown
  ip address 10.0.1.1/24
  hsrp 3
    preempt
    priority 105
    ip 10.0.1.254
!
! default via Firewalle - VLAN3
ip route 0.0.0.0/0 10.0.1.222
! VPNy via wirtualny VPN-GW - VLAN2
ip route 192.168.0.0/16 10.0.0.20
!
!
interface Ethernet1/1
  description ToR1
  switchport mode trunk
  channel-group 11 mode active
!
interface Ethernet1/49
  description Peer Link
  switchport mode trunk
  channel-group 1 mode active
!
interface Ethernet1/50
  description Peer Link
  switchport mode trunk
  channel-group 1 mode active
!
interface port-channel1
  description PortChannel Peer Link
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link
!
interface port-channel11
  description TOR1 Szafa 1
  switchport mode trunk
  vpc 11
!


Konfiguracja drugiego Nexusa jest identyczna, tylko ma inne IP dla Keepalive Linku, oraz inne priorytety dla vPC i HSRP.


Top
   
Post #2 Posted: 02 Jul 2016, 22:45 
Online
CCIE
CCIE
User avatar

Joined: 06 Jul 2006, 21:04
Posts: 804
Location: Farszafka
Ruting statyczny był od zawsze wspierany przez vPC, nie będzie z tym problemu. Musisz tylko pamiętać, żeby oba Nexusy miały identyczne wpisy, inaczej będzie blackoling.

EDIT: A, no i oczywiście zrób backup route (gorsza metryka) do sąsiedniego Nexusa, gdybyś stracił downlink do accessu z jednej strony.

_________________
ccie24081.wordpress.com


Top
   
Post #3 Posted: 03 Jul 2016, 00:13 
Offline
wannabe
wannabe

Joined: 27 Sep 2007, 01:13
Posts: 353
A ja tam tylko powiem ze nie lubie juz L2 i jak tylko mozna to implementacja Fully routed Tier1 to 3 na BGP - jest to duzo przyjemniejsze.


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 3 posts ] 

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
This Website is not sponsored by, endorsed by or affiliated with Cisco Systems, Inc. Cisco, Cisco Systems, CCDA, CCNA, CCDP, CCNP, CCIE, CCSI, CCIP, the Cisco Systems logo and the CCIE logo are trademarks or registered trademarks of Cisco Systems, Inc. in the United States and certain other countries. Używamy informacji zapisanych za pomocą cookies i podobnych technologii m.in. w celach reklamowych i statystycznych oraz w celu dostosowania naszych serwisów do indywidualnych potrzeb użytkowników. Mogą też stosować je współpracujące z nami firmy. W programie służącym do obsługi internetu można zmienić ustawienia dotyczące cookies. Korzystanie z naszych serwisów internetowych bez zmiany ustawień dotyczących cookies oznacza, że będą one zapisane w pamięci urządzenia.



Powered by phpBB® Forum Software © phpBB Limited