CCIE.pl

site 4 CCIE wannabies
Dzisiaj jest 24 lis 2017, 06:47

Strefa czasowa UTC+01:00




Nowy temat  Odpowiedz w temacie  [ Posty: 1 ] 
Autor Wiadomość
Post #1 : 11 lut 2015, 14:55 
Offline
wannabe
wannabe

Rejestracja: 31 lip 2009, 18:36
Posty: 62
Cześć,


Przebijam się przez laby na gns3vault.com. Zatrzymałem się na dłuższą chwilę na labie EIGRP-LAB

Jest tam polecenie:
Kod:
Perform mutual redistribution between EIGRP 100 and 200 on both R4 and R7. Use a strict tagging solution that ensures no routing loops; do not rely on AD or metrics to accomplish this.
Topo jak w podanym zadaniu. Proszę o opinię czy moje rozwiązanie jest poprawne, bo nie jestem pewien czy prawidłowo je sprawdzam.

Pomysł mam taki:

1. Na R4 w redystrybucji jest przypisana route-mapa, która odrzuca trasy z tag 7 a pozostałym daje tag 4
Kod:
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface Serial0/0
 ip address 192.168.48.4 255.255.255.0
 delay 3
 clock rate 128000
!
interface Serial0/1
 ip address 192.168.34.4 255.255.255.0
 clock rate 128000
!
router eigrp 200
 redistribute eigrp 100 route-map T4_D7
 network 192.168.48.4 0.0.0.0
 metric weights 0 0 0 1 0 0
 no auto-summary
!
router eigrp 100
 redistribute eigrp 200 route-map T4_D7
 network 4.4.4.4 0.0.0.0
 network 192.168.34.4 0.0.0.0
 auto-summary
!
route-map T4_D7 deny 10
 match tag 7
!
route-map T4_D7 permit 20
 set tag 4
2. Na R7 w redystrybucji jest przypisana route-mapa, która odrzuca trasy z tag 4 a pozostałym daje tag 7
Kod:
interface Loopback0
 ip address 7.7.7.7 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.78.7 255.255.255.0
 delay 1
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 192.168.67.7 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 ip address 192.168.27.7 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 200
 redistribute eigrp 100 route-map T7_D4
 network 192.168.78.7 0.0.0.0
 metric weights 0 0 0 1 0 0
 no auto-summary
!
router eigrp 100
 redistribute eigrp 200 route-map T7_D4
 network 0.0.0.0
 no auto-summary
!
route-map T7_D4 deny 10
 match tag 4
!
route-map T7_D4 permit 20
 set tag 7
3. Mój loop-prevention działa w obie strony :)

Mój pomysł na sprawdzenie był taki, żeby sprawdzić trasę z R7 do loopbacka na R3:
Kod:
IP-EIGRP (AS 200): Topology entry for 3.3.3.3/32
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 230400
  Routing Descriptor Blocks:
  192.168.27.2, from Redistributed, Send flag is 0x0
      Composite metric is (230400/0), Route is External
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 9000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 4
      External data:
        Originating router is 7.7.7.7 (this system)
        AS number of route is 100
        External protocol is EIGRP, external metric is 486400
        Administrator tag is 7 (0x00000007)
  192.168.78.8 (FastEthernet0/0), from 192.168.78.8, Send flag is 0x0
      Composite metric is (641024/640768), Route is External
      Vector metric:
        Minimum bandwidth is 1544 Kbit
        Total delay is 25040 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 3
      External data:
        Originating router is 4.4.4.4
        AS number of route is 100
        External protocol is EIGRP, external metric is 2297856
        Administrator tag is 4 (0x00000004)
IP-EIGRP (AS 100): Topology entry for 3.3.3.3/32
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 486400
  Routing Descriptor Blocks:
  192.168.27.2 (FastEthernet0/1), from 192.168.27.2, Send flag is 0x0
      Composite metric is (486400/460800), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 9000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 4
  192.168.67.6 (Serial0/0), from 192.168.67.6, Send flag is 0x0
      Composite metric is (2323456/409600), Route is Internal
      Vector metric:
        Minimum bandwidth is 1544 Kbit
        Total delay is 26000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 2
Proszę o naprowadzenie na właściwy tor.


Na górę
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat  Odpowiedz w temacie  [ Posty: 1 ] 

Strefa czasowa UTC+01:00


Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Przejdź do:  
cron
This Website is not sponsored by, endorsed by or affiliated with Cisco Systems, Inc. Cisco, Cisco Systems, CCDA, CCNA, CCDP, CCNP, CCIE, CCSI, CCIP, the Cisco Systems logo and the CCIE logo are trademarks or registered trademarks of Cisco Systems, Inc. in the United States and certain other countries. Używamy informacji zapisanych za pomocą cookies i podobnych technologii m.in. w celach reklamowych i statystycznych oraz w celu dostosowania naszych serwisów do indywidualnych potrzeb użytkowników. Mogą też stosować je współpracujące z nami firmy. W programie służącym do obsługi internetu można zmienić ustawienia dotyczące cookies. Korzystanie z naszych serwisów internetowych bez zmiany ustawień dotyczących cookies oznacza, że będą one zapisane w pamięci urządzenia.



Technologię dostarcza phpBB® Forum Software © phpBB Limited
Polski pakiet językowy dostarcza phpBB.pl