QUAGGA OSPF to HUAWEI

wszystko inne - NIE licząc sprzętu typu SOHO!!!

Moderatorzy: mikrobi, garfield, gangrena, Seba, aron

Wiadomość
Autor
miodziarz1
wannabe
wannabe
Posty: 245
Rejestracja: 26 wrz 2008, 20:58

QUAGGA OSPF to HUAWEI

#1

#1 Post autor: miodziarz1 »

witam,

mam problem z OSPFem. nie chce się połączyć moja quagga do huawei. Chińczyk wali błedami

Kod: Zaznacz cały

OSPF interface received wrong packet 1.3.6.1.2.1.14.16.2.8(ospfIfRxBadPacket)
i pożniej cała zawartosc w stylu :

Kod: Zaznacz cały

ospfRouterId, -- 
                    ospfIfIpAddress,
                    ospfAddressLessIf,
                    ospfPacketSrc,  -- 
                    ospfPacketType
i nastepny error

Kod: Zaznacz cały

OSPF interface retransmitted packet 1.3.6.1.2.1.14.16.2.10(ospfTxRetransmit)
i zawartosc

Kod: Zaznacz cały

ospfRouterId, 
ospfIfIpAddress,
ospfAddressLessIf,
ospfNbrRtrId,
ospfPacketType,
ospfLsdbType,
ospfLsdbLsid,
ospfLsdbRouterId

oczywiscie pola sa powypelniane roznymi wartosciami jednak nie podaje ich bo nie jest to chyba niezbedne

Awatar użytkownika
eprom
wannabe
wannabe
Posty: 414
Rejestracja: 17 lis 2003, 11:18
Lokalizacja: Krakow
Kontakt:

Re: QUAGGA OSPF to HUAWEI

#2

#2 Post autor: eprom »

miodziarz1 pisze:
oczywiscie pola sa powypelniane roznymi wartosciami jednak nie podaje ich bo nie jest to chyba niezbedne
Chwilowo raczej jest niezbedne, bo zostawilem szklana kule w robocie :-)
--

miodziarz1
wannabe
wannabe
Posty: 245
Rejestracja: 26 wrz 2008, 20:58

#3

#3 Post autor: miodziarz1 »

:D

Kod: Zaznacz cały

OSPF interface retransmitted packet 1.3.6.1.2.1.14.16.2.10(ospfTxRetransmit) 
     IfIpAddress     = 10.11.128.161 
     IfAddrLessIndex = 0 
     NbrIpAddress     = 10.11.128.162 
     NbrAddrLessIndex = 0 
     LsdbAreaId   = 0.0.0.0 
     LsdbType     = 5 
     LsdbLsid     =10.12.99.196 
     LsdbRouterId = 10.10.129.147 
     RouterId    = 192.168.68.254 
     NbrRouterId = 10.10.129.147 
     PacketType = 4 
 
oraz

Kod: Zaznacz cały

 OSPF interface received wrong packet 1.3.6.1.2.1.14.16.2.8(ospfIfRxBadPacket) 
     IfIpAddress     = 10.11.128.161  
     IfAddrLessIndex = 0 
     RouterId = 192.168.68.254 
     PacketSrc  = 10.11.128.162 
     PacketType = 5

Awatar użytkownika
eprom
wannabe
wannabe
Posty: 414
Rejestracja: 17 lis 2003, 11:18
Lokalizacja: Krakow
Kontakt:

#4

#4 Post autor: eprom »

Hej,

No dalej za malo informacji, przydalo by sie :

- wiecej debugow,
- konfiguracje obu stron (ospf, interfejsy)
- w jakim stanie jest adjacency po stronie Huawei oraz Quagga
--

miodziarz1
wannabe
wannabe
Posty: 245
Rejestracja: 26 wrz 2008, 20:58

#5

#5 Post autor: miodziarz1 »

huawei

Kod: Zaznacz cały

#
interface GigabitEthernet1/0/13
 stp disable
 port link-type trunk
 undo port trunk permit vlan 1
 port trunk permit vlan 500 675
 rmon statistics 13 owner null
 description test test
#
interface Vlan-interface675               
 description test
 ip address 10.10.128.161 255.255.255.252
#
ospf 1
 log-peer-change
 import-route static
 import-route direct
 area 0.0.0.0
  network 10.10.128.104 0.0.0.3
  network 10.10.128.160 0.0.0.3
#
a to z quaggi

Kod: Zaznacz cały

log stdout
log syslog
!
router ospf
 redistribute kernel
 redistribute connected
 redistribute static
 network 10.10.128.160/30 area 0.0.0.0
!
line vty
!

Seba
CCIE/CCDE Site Admin
CCIE/CCDE Site Admin
Posty: 6223
Rejestracja: 15 lip 2004, 20:35
Lokalizacja: Warsaw, PL

#6

#6 Post autor: Seba »

A ifconfig z Quaggi?
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe."
A. Einstein

miodziarz1
wannabe
wannabe
Posty: 245
Rejestracja: 26 wrz 2008, 20:58

#7

#7 Post autor: miodziarz1 »

Kod: Zaznacz cały

eth0.675@eth0: <BROADCAST,MULTICAST,UP,10000> mtu 1500 qdisc noqueue 
    link/ether 00:00:17:97:13:42 brd ff:ff:ff:ff:ff:ff
    inet 10.10.128.162/30 scope global eth0.675
    inet6 feff::fff:17ff:fe97:1342/64 scope link 
       valid_lft forever preferred_lft forever

Seba
CCIE/CCDE Site Admin
CCIE/CCDE Site Admin
Posty: 6223
Rejestracja: 15 lip 2004, 20:35
Lokalizacja: Warsaw, PL

#8

#8 Post autor: Seba »

Rozumiem, że komunikacja IP jako taka funkcjonuje, i możesz np. pingować między Huawei i Quagga.
A jak wygląda status sesji OSPF po obu stronach, bo to może nie podpowiedzieć w temacie.
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe."
A. Einstein

Awatar użytkownika
eprom
wannabe
wannabe
Posty: 414
Rejestracja: 17 lis 2003, 11:18
Lokalizacja: Krakow
Kontakt:

#9

#9 Post autor: eprom »

Ogolnie to bedzie cos raczej z tego co ponizej, posprawdzaj wszystko po koleji:

1. Area mismatch
2. Timer mismatch
3. Authentication mismatch
4. Area type mismatch (stub vs normal)
5. Subnet mask mismatch
6. Duplicate router-id
7. MTU mismatch
8. DR priority = 0 on both routers
9. Interface type mismatch

A jak dalej nic nie znajdziesz to pozostaje wireshark i ogladanie pakietow pod lupa ;-)
--

Awatar użytkownika
maverik
member
member
Posty: 39
Rejestracja: 09 maja 2013, 14:31

#10

#10 Post autor: maverik »

Wyświetl logi z quaggi, gdy zestawiasz połączeniez Huawei, w ten sposób:

prompt# tail -f /var/log/quagga/ospf.log

Najlepiej przy tej próbie wyświetl komunikaty tcpdump-em np:

tcpdump -n -i nazwa_interfejsu -v


PS. na przyszłość do wyświetlania interfejsów służy polecenie "ip addr sh" lub "ip link sh" ifconfig to zaszłość.

ODPOWIEDZ