Problem z sąsiedztwem EIGRP

Problemy związane z routingiem

Moderatorzy: mikrobi, aron, garfield, gangrena, Seba

Wiadomość
Autor
-Tomek-
wannabe
wannabe
Posty: 83
Rejestracja: 22 mar 2010, 12:11

Problem z sąsiedztwem EIGRP

#1

#1 Post autor: -Tomek- »

Witam,

Próbuję ustawić sąsiedztwo EIGRP pomiędzy dwoma routerami CISCO (2921 i C8200L).

Routery połączone się jednym interfejsem w podsieci 172.16.172.0/22 i mają końcówki odpowiednio .1 i .2.

Oto skrócona konfiguracja routera 2921:

Kod: Zaznacz cały

interface GigabitEthernet0/0
 ip address 172.16.172.1 255.255.252.0
 no ip proxy-arp
 ip pim dr-priority 1000
 ip pim sparse-dense-mode
 ip virtual-reassembly in max-reassemblies 256
 duplex auto
 speed auto

router eigrp 1
 network 172.16.172.0 0.0.3.255
 passive-interface default
 no passive-interface GigabitEthernet0/0 

A to konfiguracja C8200L:

Kod: Zaznacz cały

ip vrf RD_VRF
 rd 65000:1
 route-target export 65000:1
 route-target import 65000:1
!
interface Port-channel1.1
 encapsulation dot1Q 1 native
 ip vrf forwarding RD_VRF
 ip address 172.16.172.2 255.255.252.0
 ip pim sparse-dense-mode
 ip nat outside
!
interface GigabitEthernet0/0/0
 no ip address
 negotiation auto
 spanning-tree portfast
 channel-group 1 mode active
!
interface GigabitEthernet0/0/1
 no ip address
 negotiation auto
 spanning-tree portfast
 channel-group 1 mode active
!
interface GigabitEthernet0/0/2
 no ip address
 negotiation auto
 spanning-tree portfast
 channel-group 1 mode active
!
interface GigabitEthernet0/0/3
 no ip address
 negotiation auto
 spanning-tree portfast
 channel-group 1 mode active
!
!
router eigrp 1
 !
 address-family ipv4 vrf RD_VRF
  network 172.16.172.0 0.0.3.255
  autonomous-system 1
 exit-address-family
!
Niestety sąsiedztwo nie zestawia się.
Na pierwszym routerze dostaję komunikaty:

Kod: Zaznacz cały

Oct 12 16:20:20: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.172.2 (GigabitEthernet0/0) is down: retry limit exceeded
Oct 12 16:20:20: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.172.2 (GigabitEthernet0/0) is up: new adjacency
Oct 12 16:21:40: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.172.2 (GigabitEthernet0/0) is down: retry limit exceeded
Oct 12 16:21:40: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.172.2 (GigabitEthernet0/0) is up: new adjacency
Oct 12 16:22:59: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.172.2 (GigabitEthernet0/0) is down: retry limit exceeded
Oct 12 16:23:03: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.172.2 (GigabitEthernet0/0) is up: new adjacency
Oct 12 16:24:22: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.172.2 (GigabitEthernet0/0) is down: retry limit exceeded
Oct 12 16:24:25: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.172.2 (GigabitEthernet0/0) is up: new adjacency
Oct 12 16:25:45: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.172.2 (GigabitEthernet0/0) is down: retry limit exceeded
Oct 12 16:25:49: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 172.16.172.2 (GigabitEthernet0/0) is up: new adjacency
a na drugim tylko takie:

Kod: Zaznacz cały

Oct 12 14:25:20.222: EIGRP: Neighbor(172.16.172.1) not yet found
Oct 12 14:25:25.220: EIGRP: Neighbor(172.16.172.1) not yet found
Oct 12 14:25:30.220: EIGRP: Neighbor(172.16.172.1) not yet found
Oct 12 14:25:35.221: EIGRP: Neighbor(172.16.172.1) not yet found
Oct 12 14:25:40.220: EIGRP: Neighbor(172.16.172.1) not yet found
Oct 12 14:25:49.192: EIGRP: Neighbor(172.16.172.1) not yet found
Oct 12 14:25:51.193: EIGRP: Neighbor(172.16.172.1) not yet found
Oct 12 14:25:54.195: EIGRP: Neighbor(172.16.172.1) not yet found
Oct 12 14:25:58.693: EIGRP: Neighbor(172.16.172.1) not yet found
Oct 12 14:26:03.696: EIGRP: Neighbor(172.16.172.1) not yet found
Oct 12 14:26:08.696: EIGRP: Neighbor(172.16.172.1) not yet found
Oct 12 14:26:13.697: EIGRP: Neighbor(172.16.172.1) not yet found
Oct 12 14:26:18.710: EIGRP: Neighbor(172.16.172.1) not yet found
Oct 12 14:26:23.711: EIGRP: Neighbor(172.16.172.1) not yet found
Mam pewien trop, że problem może dotyczyć multicastów, powiem gdy pingam adres 224.0.0.10 z pierwszego routera, to nie dostaję odpowiedzi, a gdy to samo robię z drugiego routera, to ten pierwszy odpowiada:

Kod: Zaznacz cały

ping vrf RD_VRF 224.0.0.10
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.0.0.10, timeout is 2 seconds:

Reply to request 0 from 172.16.172.1, 1 ms
Żeby było ciekawiej, to na tych samych interfejsach uruchomiłem też PIM i tutaj sąsiedztwo zestawiło się bezproblemowo.

Może ktoś ma pomysł, co robię nie tak, że routery nie widzą sąsiedztwa EIGRP?

-Tomek-
wannabe
wannabe
Posty: 83
Rejestracja: 22 mar 2010, 12:11

Re: Problem z sąsiedztwem EIGRP

#2

#2 Post autor: -Tomek- »

Nie doczekałem się odpowiedzi, ale na szczęście problem udało mi się rozwiązać samemu.

Okazało się, że na jednym z portów switcha, do którego był dołączony C8200L była wpisana komenda:

Kod: Zaznacz cały

bridge multicast unregistered filtering
Odcina ona niezarejestrowany ruch multicastowy, ale niestety w tym też grupy z zakresu 224.0.0.X, więc nie należy stosować tego filtru na interfejsach, gdzie dołączone są inne switche lub routery.
U mnie powodowało to jednokierunkowe odcięcie pakietów Hello EIGRP, co z kolei przekładało się na błędy, które opisywałem.

ODPOWIEDZ