NVI PAT i problem z ruchem TFTP

Problemy związane z routingiem

Moderatorzy: mikrobi, aron, garfield, gangrena, Seba

Wiadomość
Autor
-Tomek-
wannabe
wannabe
Posty: 80
Rejestracja: 22 mar 2010, 12:11

NVI PAT i problem z ruchem TFTP

#1

#1 Post autor: -Tomek- » 20 lut 2019, 17:23

Witam,

Mam dwa różne routery (1841 i 2911) i na obu skonfigurowany PAT (NAT Overload), tylko że na pierwszym jest użyty standardowy NAT (ip nat inside/outside), a na drugim stosuję NVI (ip nat enable). Ogólnie mówiąc, na obu routerach wszystko działa - tzn. bez problemu NATowane są adresy z sieci inside na adres publiczny loopacka i mogę pingnąć dowolny host z sieci publicznej.
Problem pojawia się, gdy chcę ściągnąć coś poprzez TFTP z serwera w sieci publicznej i robię to poprzez router z włączonym NVI. Połączenie trafia do serwera, ale jego odpowiedź (z tej racji, że wychodzi nie z portu 69 a innego) już nie trafia poprzez NAT do klienta. Oczywiście drugi router z klasycznym PATem bez problemu przepuszcza ruch zwrotny TFTP z serwera.

Z tego co się orientuję za tą inteligencję NATa odpowiada wbudowana funkcjonalność ALG i zdaje się, że jest ona włączona na obu routerach.

I tu moje pytanie: czyżby zastosowanie NVI w jakiś sposób ogranicza ALG ?

Awatar użytkownika
cbr
member
member
Posty: 16
Rejestracja: 09 wrz 2015, 19:35

Re: NVI PAT i problem z ruchem TFTP

#2

#2 Post autor: cbr » 20 lut 2019, 18:58


-Tomek-
wannabe
wannabe
Posty: 80
Rejestracja: 22 mar 2010, 12:11

Re: NVI PAT i problem z ruchem TFTP

#3

#3 Post autor: -Tomek- » 21 lut 2019, 11:59

Dzięki za podrzucenie linka.
Wydaje się, że to wyczerpuje temat. Szkoda, że nawet nie planują tego poprawić....

W międzyczasie zauważyłem, że po przejściu na NVI przestały mi się translować multicasty w relacji inside->outside. Chociaż mam ustawionego static NATa dla nadawcy multicastów. Chyżby to też było kolejne ograniczenie NVI ?

ODPOWIEDZ