Strona 1 z 1

MPLS L3VPN Inter-AS Option B problem

: 14 lut 2020, 13:58
autor: natomiast
Witam,

Labuję sobie MPLS L3VPN Inter-AS Option B i natknąłem się na taki problem mianowicie nie przechodzą mi trasy z RR do PE. Może ktoś coś podpowie czego mi brakuję lub co mam źle zrobione. Mam taką topologię (analogicznie jest z "drugiej strony"):

DRUGI AS
|
ASBR2
|
P2--------RR2
|
PE2
|
CE2
Problem ogólnie polega na tym, że nie widzę tras z sąsiedniego AS na PE (sąsiedni AS zrobiłem bez routerów RR i P tak, że routery PE i ASBR są podłączone bezpośrednio dzięki czemu rozgłaszana jest trasa z CE1 ). Widzę trasy z sąsiedniego AS na ASBR i na RR ale nie ma ich na PE. Analogicznie nie widzę na ASBR trasy, ktora jest rozgłaszana przez CE (ale jest widoczna na RR -> 22.22.22.22/32)
Konfigi:

ASBR

Kod: Zaznacz cały

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface Ethernet0/0
 ip address 34.34.34.2 255.255.255.252
 mpls bgp forwarding
 mpls ip
!
interface Ethernet0/1
 ip address 45.45.45.1 255.255.255.252
 mpls ip
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
router ospf 1
 network 4.4.4.4 0.0.0.0 area 0
 network 45.45.45.0 0.0.0.3 area 0
!
router bgp 200
 bgp log-neighbor-changes
 no bgp default route-target filter
 neighbor 8.8.8.8 remote-as 200
 neighbor 8.8.8.8 update-source Loopback0
 neighbor 34.34.34.1 remote-as 100
 !
 address-family vpnv4
  neighbor 8.8.8.8 activate
  neighbor 8.8.8.8 send-community extended
  neighbor 8.8.8.8 next-hop-self
  neighbor 34.34.34.1 activate
  neighbor 34.34.34.1 send-community extended
 exit-address-family
!
P

Kod: Zaznacz cały

interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface Ethernet0/0
 ip address 56.56.56.1 255.255.255.252
 mpls ip
!
interface Ethernet0/1
 ip address 45.45.45.2 255.255.255.252
 mpls ip
!
interface Ethernet0/2
 ip address 58.58.58.1 255.255.255.252
 mpls ip
!
interface Ethernet0/3
 no ip address
 shutdown
!
router ospf 1
 network 5.5.5.5 0.0.0.0 area 0
 network 45.45.45.0 0.0.0.3 area 0
 network 56.56.56.0 0.0.0.3 area 0
 network 58.58.58.0 0.0.0.3 area 0
!
RR

Kod: Zaznacz cały

interface Loopback0
 ip address 8.8.8.8 255.255.255.255
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 ip address 58.58.58.2 255.255.255.252
 mpls ip
!
interface Ethernet0/3
 no ip address
 shutdown
!
router ospf 1
 network 8.8.8.8 0.0.0.0 area 0
 network 58.58.58.0 0.0.0.3 area 0
!
router bgp 200
 bgp log-neighbor-changes
 no bgp default route-target filter
 neighbor iBGP peer-group
 neighbor iBGP remote-as 200
 neighbor iBGP update-source Loopback0
 neighbor iBGP route-reflector-client
 neighbor 4.4.4.4 peer-group iBGP
 neighbor 6.6.6.6 peer-group iBGP
 neighbor 6.6.6.6 soft-reconfiguration inbound
 !
 address-family vpnv4
  neighbor iBGP send-community extended
  neighbor 4.4.4.4 activate
  neighbor 6.6.6.6 activate
 exit-address-family
!
PE

Kod: Zaznacz cały

ip vrf A
 rd 100:1
 route-target export 10:10
 route-target import 10:10
!

interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface Ethernet0/0
 ip address 56.56.56.2 255.255.255.252
 mpls ip
!
interface Ethernet0/1
 ip vrf forwarding A
 ip address 20.1.1.1 255.255.255.252
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
router ospf 1
 network 6.6.6.6 0.0.0.0 area 0
 network 56.56.56.0 0.0.0.3 area 0
!
router bgp 200
 bgp log-neighbor-changes
 no bgp default route-target filter
 neighbor 8.8.8.8 remote-as 200
 neighbor 8.8.8.8 update-source Loopback0
 !
 address-family vpnv4
  neighbor 8.8.8.8 activate
  neighbor 8.8.8.8 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf A
  neighbor 20.1.1.2 remote-as 65002
  neighbor 20.1.1.2 activate
 exit-address-family
!
Trasy na poszczególnych urządzeniach: (11.11.11.11/32 to trasa rozgłaszana przez sąsiedni AS).

Kod: Zaznacz cały

ASBR2#sho bgp vpnv4 un al
     Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:1
 *>  11.11.11.11/32   34.34.34.1                             0 100 65001 i

RR2#sho bgp vpnv4 un all
     Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:1
 *>i 11.11.11.11/32   4.4.4.4                  0    100      0 100 65001 i
 *>i 22.22.22.22/32   6.6.6.6                  0    100      0 65002 i


PE2#sho bgp vpnv4 unicast all
     Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf A)
 *>  22.22.22.22/32   20.1.1.2                 0             0 65002 i
Używam Eve-ng do symulacji.
Z góry dziekuję i pozdrawiam :D

Re: MPLS L3VPN Inter-AS Option B problem

: 14 lut 2020, 18:50
autor: martino76
Tak na szybko czy RT import jest taki sam jak RT export na urządzeniu które rozgłasza 11.11.11.11/32 z drugiego AS?

Pozdro,

Re: MPLS L3VPN Inter-AS Option B problem

: 17 lut 2020, 09:11
autor: natomiast
Tak, RT jest taki sam. Chociaż czy to nie jest tak, że tylko w opcji A jest to istotnie globalnie?

Re: MPLS L3VPN Inter-AS Option B problem

: 17 lut 2020, 14:56
autor: martino76
RT ma znaczenie, bo to jest extended community, na podstawie ktorego MP-BGP decyduje czy dany prefix ma byc zaimportowany do danego VRF'a.

Pokaz

Kod: Zaznacz cały

sh bgp vpnv4 unicast all 
z RR.

Pozdro,

Re: MPLS L3VPN Inter-AS Option B problem

: 17 lut 2020, 15:05
autor: natomiast
Jest wynik z RR2 w poście ;)

Re: MPLS L3VPN Inter-AS Option B problem

: 17 lut 2020, 15:14
autor: martino76
sorry mialem na mysli dla tej trassy 11.11.11.11 chcialbym zobaczyc jakie extended community ma, NH itd.

Re: MPLS L3VPN Inter-AS Option B problem

: 17 lut 2020, 15:26
autor: natomiast
Nie wiem czy o to chodziło?

Kod: Zaznacz cały

RR2#sho bgp vpnv4 unicast all 11.11.11.11 255.255.255.255
BGP routing table entry for 100:1:11.11.11.11/32, version 4
Paths: (1 available, best #1, no table)
  Not advertised to any peer
  Refresh Epoch 1
  100 65001
    4.4.4.4 (metric 21) (via default) from 4.4.4.4 (4.4.4.4)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Extended Community: RT:10:10
      mpls labels in/out nolabel/24
      rx pathid: 0, tx pathid: 0x0


Re: MPLS L3VPN Inter-AS Option B problem

: 17 lut 2020, 16:24
autor: martino76
Ok dodaj

Kod: Zaznacz cały

neighbor iBGP route-reflector-client
na RR pod vpnv4 AF, bo obecnie ten prefix nie jest rozglaszany

Kod: Zaznacz cały

RR2#sho bgp vpnv4 unicast all 11.11.11.11 255.255.255.255
BGP routing table entry for 100:1:11.11.11.11/32, version 4
Paths: (1 available, best #1, no table)
  Not advertised to any peer
Pozdro,

Re: MPLS L3VPN Inter-AS Option B problem

: 18 lut 2020, 09:40
autor: natomiast
Dzieki martino76! To było to.
Pozdro