PortChannel i LAG pomiędzy Cisco Catalyst i Juniper QFX Temat rozwiązany

Problemy związane ze switchingiem

Moderatorzy: mikrobi, aron, garfield, gangrena, Seba

Wiadomość
Autor
h33ren
member
member
Posty: 47
Rejestracja: 15 paź 2017, 13:46

Re: PortChannel i LAG pomiędzy Cisco Catalyst i Juniper QFX

#16

#16 Post autor: h33ren » 05 mar 2018, 21:04

Postanowiłem zacząć od nowa tym razem ze switchem Cisco 4948.

Konfiguracja po stronie Cisco

Kod: Zaznacz cały

spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree extend system-id

interface Port-channel1
 	 switchport
 	 switchport trunk encapsulation dot1q
 	 switchport trunk allowed vlan 1-1873,1875-4094
 	 switchport mode trunk
 	 flowcontrol receive on

interface TenGigabitEthernet1/49
 	 description PORT CHANNEL 1
 	 switchport trunk encapsulation dot1q
 	 switchport trunk allowed vlan 1-1873,1875-4094
 	 switchport mode trunk
 	 channel-group 1 mode active
 	!
interface TenGigabitEthernet1/50
 	 description PORT CHANNEL 1
 	 switchport trunk encapsulation dot1q
 	 switchport trunk allowed vlan 1-1873,1875-4094
 	 switchport mode trunk
	 channel-group 1 mode active
Można powiedzieć klasyk.

Teraz po stronie Junipera.

Kod: Zaznacz cały

    xe-0/0/8 {
        ether-options {
            no-auto-negotiation;
            802.3ad ae10;
        }
    }

    xe-1/0/20 {
        ether-options {
            no-auto-negotiation;
            802.3ad ae10;
        }
    }

    ae10 {
        native-vlan-id 1;
        aggregated-ether-options {
            minimum-links 1;
            link-speed 10g;
            lacp {
                active;
            }
        }
        unit 0 {
            family ethernet-switching {
                interface-mode trunk;
                vlan {
                    members [ 10 14 16 30 109-116 120-122 130-132 136 140-141 143-145 150 153 160 166 169-170 172-174 191 199 202 212 240 999 ];
                }
            }
        }
    }

protocols {
    igmp {
        interface irb.166 {
            version 2;
        }
    }
    lldp {
        interface all;
    }
    lldp-med {
        interface all;
    }
    igmp-snooping {
        vlan default;
        vlan all;
    }
    vstp {
        vlan 1;
        vlan all;
    }
}
Aha, ciekawie to wygląda gdy na Juniper sprawdziłem logi.

Kod: Zaznacz cały

show log messages
o 10:07:40 włożyłem do portu 0/0/8 na Junku kabel z portu Gi1/49 od Cisco, i jak widać LAG się podniósł.

ale zaraz po chwili o 10:07:45 włożyłem drugi kabel do portu 1/0/20 z portu Gi1/50 od Cisco, no i się wszystko posypało. Oba porty się zablokowały. Wyjęcie jednego z kabli powoduje "odblokowanie" LAGu. No ale co to za LAG z jednym kablem, ja muszę mieć redundancję.

Tak to wygląda w logu:

Kod: Zaznacz cały

Mar  5 10:07:40  cvc fpc0 sfp-0/0/8 link 8 SFP receive power low  alarm cleared
Mar  5 10:07:40  cvc fpc0 sfp-0/0/8 link 8 SFP receive power low  warning cleared
Mar  5 10:07:44  cvc kernel: lag_bundlestate_ifd_change: bundle ae10 is now Up. uplinks 1 >= min_links 1
Mar  5 10:07:45  cvc fpc0 LBCM-L2,brcm_mcast_agg_member_add_l3(),1433:Unexpcted NH Id:131097, NH type:Indirect
Mar  5 10:07:45  cvc fpc0 LBCM-L2,brcm_mcast_agg_member_add_l3(),1433:Unexpcted NH Id:131085, NH type:Indirect
Mar  5 10:07:45  cvc fpc0 LBCM-L2,brcm_mcast_agg_member_add_l3(),1433:Unexpcted NH Id:131090, NH type:Indirect
Mar  5 10:07:45  cvc fpc0 LBCM-L2,brcm_mcast_agg_member_add_l3(),1433:Unexpcted NH Id:131095, NH type:Indirect
Mar  5 10:07:45  cvc fpc0 LBCM-L2,brcm_mcast_agg_member_add_l3(),1433:Unexpcted NH Id:131083, NH type:Indirect
Mar  5 10:08:34  cvc fpc0 clksync_phy_driver_enable_tc_per_port: Failed to get PIC from ifd xe-1/0/20
VLAN 1 skonfigurowałem jako native, gdyż często w tym temacie na forach poruszane było że ten VLAN musi być skonfigurowany na interfejsie żeby BPDU mogły latać pomiędzy switchami. Mimo to nic to nie dało.
CCNA R&S | CCNA Sec

Awatar użytkownika
misz
member
member
Posty: 41
Rejestracja: 24 kwie 2009, 09:41

Re: PortChannel i LAG pomiędzy Cisco Catalyst i Juniper QFX

#17

#17 Post autor: misz » 30 mar 2018, 23:09

Hej,

Poniżej załączam działająca konfigurację.

Kod: Zaznacz cały

## Cisco:
interface Port-channel10
 switchport
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 no ip address


interface GigabitEthernet2/1
 switchport
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
 no ip address
 channel-protocol lacp
 channel-group 10 mode passive


## Juniper:
chassis {
    aggregated-devices {
        ethernet {
            device-count 2;
        }
    }
    
show configuration interfaces ae1
aggregated-ether-options {
    lacp {
        active;
        periodic fast;
    }
}
unit 0 {
    family ethernet-switching {
        port-mode trunk;
        vlan {
            members all;
        }
    }
}
Przydatny link: http://networktest.com/jnpriop/cookbook.pdf

Jeśli nie zadziała wypluj:
- Wersje softu
- konfigurację z obu przełączników

h33ren
member
member
Posty: 47
Rejestracja: 15 paź 2017, 13:46

Re: PortChannel i LAG pomiędzy Cisco Catalyst i Juniper QFX

#18

#18 Post autor: h33ren » 29 maja 2018, 12:36

Witam,

No w końcu zestawiłem STP pomiędzy Cisco a Juniperem, ale co ciekawe tylko między VSS a VC. Nadal mam problem między VC a Catalyst 3560.

ae0 to LAG pomiędzy VSS a VC i musiałem taką zastosować konfigurację.

Kod: Zaznacz cały

protocols {
    rstp {
        bridge-priority 4k;
    }
    vstp {
        bpdu-block-on-edge;
        interface ae0;
        interface ae14 {
            no-root-port;
        }

        vlan all {
            bridge-priority 4k;
        }
    }
}
Natomiast do Catalysta 3560 mam LAG ae14. Próbowałem również bez opcji no-root-port.

A to status STP z VC (Juniper), wklejam tylko dwa VLANy ale jest ich więcej.

Kod: Zaznacz cały

root@cvc> show spanning-tree interface

Spanning tree interface parameters for VLAN 10

Interface                  Port ID    Designated         Designated         Port    State  Role
                                       port ID           bridge ID          Cost
ae0                          128:3        128:3   4106.d007ca44b990         1000    FWD    DESG

Spanning tree interface parameters for VLAN 14

Interface                  Port ID    Designated         Designated         Port    State  Role
                                       port ID           bridge ID          Cost
ae0                          128:3        128:3   4110.d007ca44b990         1000    FWD    DESG
ae14                        128:17       128:17   4110.d007ca44b990        10000    BLK    DIS
Po stronie Cisco w logu widoczne jest tylko.

Kod: Zaznacz cały

May 29 02:41:43 UTC: %SPANTREE-2-LOOPGUARD_BLOCK: Loop guard blocking port Port-channel1 on VLAN0202.
Konfiguracja na Cisco jest standardowa.

Kod: Zaznacz cały

interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1-1870,1875-4094
 switchport mode trunk
 switchport nonegotiate

interface GigabitEthernet0/49
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1-1870,1875-4094
 switchport mode trunk
 switchport nonegotiate
 channel-protocol lacp
 channel-group 1 mode passive
!
interface GigabitEthernet0/50
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1-1870,1875-4094
 switchport mode trunk
 switchport nonegotiate
 channel-protocol lacp
 channel-group 1 mode passive
!
Mało tego, nie da się wyczyścić tego stanu BLK DIS z interfejsu ae14.

Kod: Zaznacz cały

root@cvc> clear error bpdu interface ae14
BPDU-block not active on interface ae14
Jakieś sugestie, co jest nie tak na LAGu ae14 ? I czemu STP blokuje cały LAG ?
CCNA R&S | CCNA Sec

Awatar użytkownika
konradrz
CCIE
CCIE
Posty: 326
Rejestracja: 23 sty 2008, 14:21
Lokalizacja: Singapore, SG
Kontakt:

Re: PortChannel i LAG pomiędzy Cisco Catalyst i Juniper QFX

#19

#19 Post autor: konradrz » 30 maja 2018, 07:45

A pokaż fizyczną topologię? Bo teraz wygląda tak, jakby VC Ci nie działał poprawnie, i Catalyst "widział" twoje Jupki jako dwa oddzielne pudełka, z których jedno nie wysyła BPDU (i dlatego załącza się loopguard)
A próbowałeś wyłączyć loopguard? (tylko nie w produkcji, heh)

h33ren
member
member
Posty: 47
Rejestracja: 15 paź 2017, 13:46

Re: PortChannel i LAG pomiędzy Cisco Catalyst i Juniper QFX

#20

#20 Post autor: h33ren » 31 maja 2018, 12:29

Tutaj topologia.

https://www.jednostki-wojskowe.pl/images/stp.png

Nie wiem dlaczego ale nie działa wstawianie obrazów na forum, ktoś wie ?

Generalnie coraz bardziej skłaniam się do tego że problem leży po stronie konfigu na Juniperze, dlatego że ja fizycznie kable mam porązłączane na LAGu ae14 i ae15 a stan dalej jest BLK DIS.

Co ciekawe tak naprawdę LAGu ae15 nawet nie zdążyłem nigdy podłączyć.

A więc problem na bank po stronie Junka. Czyżbym nie musiał w ogóle tych interfejsów dodawać gałęzi konfiguracji protocols vstp ? Tylko ten jeden pomiędzy VC a VSS ?

Bo tak jak jest na tym schemacie topologii STP pomiędzy VC a VSS działa, i nawet jak teraz ten switch Cat 3560 jest podłączony do VSS to on widzi że VC jest Root Bridge dla sieci. Widzę to po komendzie show spanning-tree root
CCNA R&S | CCNA Sec

h33ren
member
member
Posty: 47
Rejestracja: 15 paź 2017, 13:46

Re: PortChannel i LAG pomiędzy Cisco Catalyst i Juniper QFX

#21

#21 Post autor: h33ren » 31 maja 2018, 16:49

Dodam tylko dla jasności że target to przeniesienie połączenia Po1<>Po315 na Po1<>ae14
CCNA R&S | CCNA Sec

eljan
member
member
Posty: 37
Rejestracja: 01 lut 2011, 10:14

Re: PortChannel i LAG pomiędzy Cisco Catalyst i Juniper QFX

#22

#22 Post autor: eljan » 12 cze 2018, 01:46

Dzisiaj testowałem LAG-a pomiędzy QFX (Junos: 15.1X53-D60.4) a switchem cisco (Version 15.2)
Na junosie został stworzony LAG ae0 i dodane do niego dwa porty xe-0/0/10 oraz xe-0/0/11:

Kod: Zaznacz cały

Juniper

#run show configuration interfaces ae0 
aggregated-ether-options {
    lacp {
        active;
    }
}
unit 0 {
    family ethernet-switching {
        interface-mode trunk;
        vlan {
            members v_5;
        }
    }
}

#run show configuration interfaces xe-0/0/10  
ether-options {
    802.3ad ae0;
}

#run show configuration interfaces xe-0/0/11    
ether-options {
    802.3ad ae0;
}
 
#run show lacp interfaces 
Aggregated interface: ae0
    LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
      xe-0/0/10      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/10    Partner    No    No   Yes  Yes  Yes   Yes     Slow    Active
      xe-0/0/11      Actor    No    No   Yes  Yes  Yes   Yes     Fast    Active
      xe-0/0/11    Partner    No    No   Yes  Yes  Yes   Yes     Slow    Active
    LACP protocol:        Receive State  Transmit State          Mux State 
      xe-0/0/10                 Current   Slow periodic Collecting distributing
      xe-0/0/11                 Current   Slow periodic Collecting distributing
Natomiast na przełaczniku cisco stowrzony port-channel 2 też jako active i z dodanymi dwoma portami e1/0 oraz e1/1

Kod: Zaznacz cały

Cisco

Switch#sh run int po2
Building configuration...

Current configuration : 92 bytes
!
interface Port-channel2
 switchport trunk encapsulation dot1q
 switchport mode trunk
end

Switch#sh run int e1/0
Building configuration...

Current configuration : 119 bytes
!
interface Ethernet1/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode active
end

Switch#sh run int e1/1
Building configuration...

Current configuration : 119 bytes
!
interface Ethernet1/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 2 mode active
end

Switch#sh etherc sum
!
!
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
2      Po2(SU)         LACP      Et1/0(P)    Et1/1(P)  
Na junosie stworzyłem irb.5 natomiast na cisco interface vlan 5. Ping przechodził.

h33ren
member
member
Posty: 47
Rejestracja: 15 paź 2017, 13:46

Re: PortChannel i LAG pomiędzy Cisco Catalyst i Juniper QFX

#23

#23 Post autor: h33ren » 12 cze 2018, 14:57

Problem chyba rozwiązany, ale jutro potwierdzę.

W każdym razie Cisco 4948 <> QFX 5110 działa.
CCNA R&S | CCNA Sec

eljan
member
member
Posty: 37
Rejestracja: 01 lut 2011, 10:14

Re: PortChannel i LAG pomiędzy Cisco Catalyst i Juniper QFX

#24

#24 Post autor: eljan » 16 cze 2018, 13:39

Jak problem z LAG miedzy juniper a cisco, wstał ?
Btw jaki zwykle STP mode ustawiacie miedzy juniperm a cisco rstp czy vstp ?
Odnośnie MVRP między junierem a cisco. Zauważyłem że tylko na niektórych urządzaniach cisco jest możliwość aktywacji protokołu MVRP tj. nexus 7k, 9k ?

h33ren
member
member
Posty: 47
Rejestracja: 15 paź 2017, 13:46

Re: PortChannel i LAG pomiędzy Cisco Catalyst i Juniper QFX  Temat rozwiązany

#25

#25 Post autor: h33ren » 21 cze 2018, 16:03

No i w końcu problem rozwiązany !

W połączeniu pomiędzy Cat3560G 1 Gigabit fiber, a QFX 5110 , po stronie Cisco w konfiguracji interfejsu MUSI być wklepana komenda

Kod: Zaznacz cały

speed nonegotiate
Bez tego interfejs po prostu pozostaje martwy.

Co najgorsze, nie dało się tego w żaden sposób debug'ować, bo po prostu miałem włączony debug all, i nic dosłownie się nie działo.

Więc troubleshooting polegał na zasadzie walenia w ciemno ustawieniami po stronie Cisco i Junipera.

Masakra, no ale się udało znaleźć to cholerne ustawienie.
CCNA R&S | CCNA Sec

saiqard
wannabe
wannabe
Posty: 327
Rejestracja: 09 lip 2012, 22:10
Lokalizacja: Wałbrzych/Wrocław

Re: PortChannel i LAG pomiędzy Cisco Catalyst i Juniper QFX

#26

#26 Post autor: saiqard » 25 cze 2018, 10:11

gratulacje :) trochę Cie to zmęczyło :)

Kyniu
wannabe
wannabe
Posty: 3414
Rejestracja: 04 lis 2006, 16:23

Re: PortChannel i LAG pomiędzy Cisco Catalyst i Juniper QFX

#27

#27 Post autor: Kyniu » 25 cze 2018, 19:43

h33ren pisze:
21 cze 2018, 16:03
Więc troubleshooting polegał na zasadzie walenia w ciemno ustawieniami po stronie Cisco i Junipera.
To jak Cię ktoś, kiedyś spyta "czym się różni wiedza od doświadczenia" to będziesz wiedział jak odpowiedzieć ;)
Always start with why do you need this?, not how will we do it?.
CCNA: R&S, Security, Wireless, Collaboration. MCSE: Cloud Platform and Infrastructure, Server Infrastructure.

ODPOWIEDZ