CCIE.pl

site 4 CCIE wannabies
Dzisiaj jest 14 gru 2017, 20:03

Strefa czasowa UTC+01:00




Nowy temat  Odpowiedz w temacie  [ Posty: 7 ] 
Autor Wiadomość
Post #1 : 11 kwie 2017, 09:19 
Offline
fresh
fresh

Rejestracja: 22 lut 2017, 14:44
Posty: 7
Witam
Od wczoraj mam problem z punktowym brakiem przydziału adresów IP na różnych komputerach.
W trakcie pracy lub zaraz po uruchomieniu komputera traci adres, wszystko wraca do normy po restarcie routera, router C1921.

Macie jakieś pomysły?


Na górę
Post #2 : 11 kwie 2017, 10:46 
Offline
CCIE
CCIE
Awatar użytkownika

Rejestracja: 06 maja 2005, 01:32
Posty: 1388
Lokalizacja: Dortmund, DE
Tak, mamy. Sprawdz wielkosc puli adresow przydzielanych w LANie, skonfigurowanej na tym routerze. Byc moze cala pula jest wykorzystywana i brakuje nowych IP dla nowych urzadzen.

Pozdruffka!

_________________
Never stop exploring :)


Na górę
Post #3 : 12 kwie 2017, 09:41 
Offline
fresh
fresh

Rejestracja: 22 lut 2017, 14:44
Posty: 7
Tak, tyle że po restarcie wszystko wraca do normy, gdyby brakowało adresów 2 inne urządzenia przestałyby działać, a tak nie jest.


Na górę
Post #4 : 12 kwie 2017, 10:17 
Offline
wannabe
wannabe

Rejestracja: 04 lis 2006, 16:23
Posty: 3388
debug ip dhcp server events
debug ip dhcp server packet

Zbierz dane, przeanalizuj i wyciągnij wnioski.

_________________
Always start with why do you need this?, not how will we do it?.
CCNA: R&S, Security, Wireless, Collaboration. MCSE: Cloud Platform and Infrastructure, Server Infrastructure.


Na górę
Post #5 : 12 kwie 2017, 11:50 
Offline
member
member

Rejestracja: 14 sty 2011, 16:57
Posty: 48
Lokalizacja: WRO
Co to za środowisko? Produkcyjne/testowe? Pokaż jak masz skonfigurowany serwer i pulę DHCP + ip dhcp excluded address.

Dodatkowo sprawdź ile adresów masz aktualnie wykorzystywanych komendą:

show ip dhcp binding

Może masz kogoś w sieci kto skutecznie przeprowadza DHCP starvation attack. Pomyśl o włączeniu dhcp snooping jeżeli masz na stanie switche cisco lub innych vendorów wspierających ten feature.

Pozdrawiam


Na górę
Post #6 : 13 kwie 2017, 12:58 
Offline
fresh
fresh

Rejestracja: 22 lut 2017, 14:44
Posty: 7
Sieć produkcyjna, poniżej zrzut z running-config, polecenie binding,log, pool - oddzielone --------------.
Patrząc na daty wygląda tak jakby kończyła się dzierżawa i nie mogła się odnowić po uruchomienia komputera. Po nadaniu adresu wolnego statycznie również nie ma połączenia, wszystko się poprawia po restarcie routera.
Jeszcze jedna sprawa wczoraj ustawiłem godzinę i datę(konfiguracja zapisana), dziś po restarcie routera godzina cofnęła się o 3h.



!
ip dhcp excluded-address 192.168.100.1 192.168.100.126
ip dhcp excluded-address 192.168.100.175
ip dhcp excluded-address 192.168.100.240 192.168.100.255
ip dhcp excluded-address 192.168.100.127
ip dhcp excluded-address 192.168.100.128
ip dhcp excluded-address 192.168.100.238 192.168.100.239
ip dhcp excluded-address 192.168.100.181
ip dhcp excluded-address 192.168.100.131
ip dhcp excluded-address 192.168.100.130
ip dhcp excluded-address 192.168.100.156
!
ip dhcp pool LAN-A
import all
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1
dns-server 192.168.100.9 8.8.8.8
domain-name b.local
!
ip dhcp pool LAN-B
network 192.168.102.0 255.255.255.0
dns-server 192.168.100.9 8.8.8.8
default-router 192.168.100.1
!
!
!

interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description WAN
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
description LAN
ip address 192.168.100.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!


-----------------------------------------------------------------------------------

Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
192.168.100.135 01ac.220b.748c.ec Apr 14 2017 06:15 AM Automatic
192.168.100.136 0100.aefa.d392.58 Apr 14 2017 09:06 AM Automatic
192.168.100.137 01fc.aa14.1187.0f Apr 14 2017 06:09 AM Automatic
192.168.100.145 011c.1b0d.7a13.cb Apr 14 2017 05:57 AM Automatic
192.168.100.146 0150.e549.c23f.7c Apr 14 2017 06:25 AM Automatic
192.168.100.148 0174.d435.9c9b.aa Apr 14 2017 06:25 AM Automatic
192.168.100.150 01fc.aa14.11a2.9c Apr 14 2017 05:59 AM Automatic
192.168.100.152 011c.1b0d.7a0b.7f Apr 14 2017 06:00 AM Automatic
192.168.100.159 0190.2b34.5f94.06 Apr 14 2017 06:25 AM Automatic
192.168.100.160 0100.2618.bb69.b4 Apr 14 2017 06:00 AM Automatic
192.168.100.162 0174.d435.5e87.20 Apr 14 2017 06:02 AM Automatic
192.168.100.163 01ac.220b.7728.99 Apr 14 2017 06:59 AM Automatic
192.168.100.164 0190.2b34.5e8c.e9 Apr 14 2017 06:03 AM Automatic
192.168.100.165 48db.50b3.591c Apr 14 2017 06:05 AM Automatic
192.168.100.166 0142.e396.d87b.f7 Apr 14 2017 06:25 AM Automatic
192.168.100.167 0184.3838.5f91.1c Apr 14 2017 09:23 AM Automatic
192.168.100.168 01e8.508b.13a4.e3 Apr 14 2017 09:23 AM Automatic
192.168.100.169 0120.5531.e4c6.11 Apr 14 2017 07:51 AM Automatic
192.168.100.170 01fc.aa14.a58f.85 Apr 14 2017 08:42 AM Automatic
192.168.100.174 011c.1b0d.691b.22 Apr 14 2017 08:19 AM Automatic
192.168.100.176 5055.27c1.5644 Apr 14 2017 09:32 AM Automatic
192.168.100.177 0100.1966.b9c1.b5 Apr 14 2017 09:35 AM Automatic
192.168.100.178 01ac.0d1b.eac4.a4 Apr 14 2017 07:16 AM Automatic
192.168.100.179 0174.d02b.2c6f.a5 Apr 14 2017 08:29 AM Automatic
192.168.100.182 d065.cab9.259a Apr 14 2017 09:20 AM Automatic
192.168.100.183 0140.8d5c.a4e0.0d Apr 14 2017 07:53 AM Automatic
192.168.100.184 0140.8d5c.a881.0e Apr 14 2017 08:02 AM Automatic
192.168.100.187 c407.2fba.6de7 Apr 14 2017 08:04 AM Automatic
192.168.100.188 0124.4b81.5fe8.cb Apr 14 2017 08:35 AM Automatic
192.168.100.190 0150.e549.d031.5b Apr 14 2017 08:54 AM Automatic
192.168.100.210 0120.cf30.f093.3c Apr 14 2017 07:48 AM Automatic
192.168.100.226 0190.2b34.bb61.e0 Apr 14 2017 06:28 AM Automatic



-----------------------------------------------------------------------------------------------------

Syslog logging: enabled (0 messages dropped, 2 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.



No Inactive Message Discriminator.


Console logging: level debugging, 70 messages logged, xml disabled,
filtering disabled
Monitor logging: level debugging, 0 messages logged, xml disabled,
filtering disabled
Buffer logging: level warnings, 45 messages logged, xml disabled,
filtering disabled
Exception Logging: size (4096 bytes)
Count and timestamp logging messages: disabled
Persistent logging: disabled

No active filter modules.

Trap logging: level informational, 72 message lines logged
Logging Source-Interface: VRF Name:

Log Buffer (51200 bytes):

*Apr 13 07:59:22.043: %SSH-3-NO_MATCH: No matching hostkey algorithm found: client ssh-dss server ssh-rsa
*Apr 13 07:59:22.555: %SSH-3-DH_SIZE: DH public key size > DH group key size(128)
*Apr 13 07:59:22.795: %SSH-3-NO_MATCH: No matching hostkey algorithm found: client ecdsa-sha2-nistp256 server ssh-rsa
*Apr 13 07:59:23.103: %SSH-3-NO_MATCH: No matching hostkey algorithm found: client ecdsa-sha2-nistp384 server ssh-rsa
*Apr 13 07:59:23.415: %SSH-3-NO_MATCH: No matching hostkey algorithm found: client ecdsa-sha2-nistp521 server ssh-rsa
*Apr 13 08:01:50.147: %SSH-3-NO_MATCH: No matching hostkey algorithm found: client ssh-dss server ssh-rsa
*Apr 13 08:01:50.639: %SSH-3-DH_SIZE: DH public key size > DH group key size(128)
*Apr 13 08:01:50.915: %SSH-3-NO_MATCH: No matching hostkey algorithm found: client ecdsa-sha2-nistp256 server ssh-rsa
*Apr 13 08:01:51.255: %SSH-3-NO_MATCH: No matching hostkey algorithm found: client ecdsa-sha2-nistp384 server ssh-rsa
*Apr 13 08:01:51.563: %SSH-3-NO_MATCH: No matching hostkey algorithm found: client ecdsa-sha2-nistp521 server ssh-rsa
*Apr 13 08:04:50.587: %DHCPD-4-PING_CONFLICT: DHCP address conflict: server pinged 192.168.100.186.
*Apr 13 08:54:37.887: %DHCPD-4-PING_CONFLICT: DHCP address conflict: server pinged 192.168.100.189.

------------------------------------------------------------------------------------------------------------
R1#show ip dhcp pool

Pool LAN-A :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 254
Leased addresses : 32
Pending event : none
1 subnet is currently in the pool :
Current index IP address range Leased addresses
192.168.100.191 192.168.100.1 - 192.168.100.254 32

Pool LAN-B :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 254
Leased addresses : 0
Pending event : none
1 subnet is currently in the pool :
Current index IP address range Leased addresses
192.168.102.1 192.168.102.1 - 192.168.102.254 0


Na górę
Post #7 : 13 kwie 2017, 22:17 
Offline
CCIE
CCIE
Awatar użytkownika

Rejestracja: 23 sty 2008, 14:21
Posty: 300
Lokalizacja: Singapore, SG
Cytuj:
Jeszcze jedna sprawa wczoraj ustawiłem godzinę i datę(konfiguracja zapisana), dziś po restarcie routera godzina cofnęła się o 3h.
To, na próbę, ustaw lease na jakiś dłuuugi czas (np miesiąc) i zobacz czy się coś zmieni.

Te logi z DHCP to dlatego, że po rebucie Twój router chciał rozdać już używane adresy.
Jak koledzy podpowiedzieli, 'debug' użyj, nie zwykłego logu.
Update: i, zgodnie z tym artykułem, strzel sobie `clear ip dhcp conflict *' i potem `no ip dhcp conflict logging'.

BTW, może jakiś ACL ustaw, żeby Ci nie skanowali SSH?


Na górę
Wyświetl posty nie starsze niż:  Sortuj wg  
Nowy temat  Odpowiedz w temacie  [ Posty: 7 ] 

Strefa czasowa UTC+01:00


Kto jest online

Użytkownicy przeglądający to forum: Google [Bot] i 1 gość


Nie możesz tworzyć nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Przejdź do:  
cron
This Website is not sponsored by, endorsed by or affiliated with Cisco Systems, Inc. Cisco, Cisco Systems, CCDA, CCNA, CCDP, CCNP, CCIE, CCSI, CCIP, the Cisco Systems logo and the CCIE logo are trademarks or registered trademarks of Cisco Systems, Inc. in the United States and certain other countries. Używamy informacji zapisanych za pomocą cookies i podobnych technologii m.in. w celach reklamowych i statystycznych oraz w celu dostosowania naszych serwisów do indywidualnych potrzeb użytkowników. Mogą też stosować je współpracujące z nami firmy. W programie służącym do obsługi internetu można zmienić ustawienia dotyczące cookies. Korzystanie z naszych serwisów internetowych bez zmiany ustawień dotyczących cookies oznacza, że będą one zapisane w pamięci urządzenia.



Technologię dostarcza phpBB® Forum Software © phpBB Limited
Polski pakiet językowy dostarcza phpBB.pl