brak sygnału wołania po transferze połączenia

Problemy związane z Unified Communications

Moderatorzy: mikrobi, aron, garfield, gangrena, Seba

Wiadomość
Autor
gitakam
member
member
Posty: 20
Rejestracja: 13 gru 2016, 11:08

brak sygnału wołania po transferze połączenia

#1

#1 Post autor: gitakam » 24 kwie 2018, 16:16

Cześć,

mam następującą konfigurację:

MIASTO -> SIP TRUNK (lub ISDN) -> ZAPOWIEDZ_BACD CME -> OPERATOR -> TELEFON WEWNĘTRZNY 2

Gdy dzwoni MIASTO przez SIP TRUNK, zgłasza się zapowiedź AA na CME (skrypt its-CISCO-2.0.3.0.tcl). Następnie połączenie trafia do OPERATOR. OPERATOR wykonuje transfer rozmowy na TELEFON WEWNĘTRZNY 2, w tle odtwarzana jest dla MIASTO muzyka MoH. Jeżeli nikt na TELEFON WEWNĘTRZNY 2 nie odbiera, operator realizuje transfer "na ślepo" na TELEFON WEWNĘTRZNY 2. Po tym procesie MIASTO czeka na zgłoszenie TELEFON WEWNĘTRZNY 2, ale nie słyszy sygnału wołania, tylko ciszę, aż nie zostanie odebrane połączenie na TELEFON WEWNĘTRZNY 2. W rezultacie dzwoniący z MIASTO zazwyczaj rozłącza się, ponieważ słyszy ciszę, aż do czasu gdy ktoś na TELEFON WEWNĘTRZNY 2 nie podniesie słuchawki.

Jak wyeliminować ciszę u dzwoniącego z zewnątrz i zastąpić sygnałem wołania?

Gdy testuję to w konfiguracji:

TELEFON WEWNĘTRZNY 1 -> ZAPOWIEDZ_BACD CME -> OPERATOR -> TELEFON WEWNĘTRZNY 2

działa bez problemu - po transferze na ślepo, TELEFON WEWNĘTRZNY 1 słyszy wołanie.

Prawdopodobnie jakiś błąd jest w mojej konfiguracji SIP TRUNK (chociaż tak samo zachowuje się to na ISDN), ale nie potrafię zlokalizować.

Konfiguracja:

Kod: Zaznacz cały


!
ip dhcp pool VOICE
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.1
 option 150 ip 192.168.0.1
!
!
!
!
!
voice-card 0
!
!
!
voice service voip
 ip address trusted list
  ipv4 xx.xx.xx.xx
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
  early-offer forced
  midcall-signaling passthru
!
!
!
!
!
!
voice translation-rule 1
 rule 1 /^.*/ /222/
!
!
voice translation-profile IN
translate called 1
!
!
!
!
application
 service aa flash:its-CISCO.2.0.3.0.tcl
  paramspace english index 0
  paramspace english language en
  param operator 101
  paramspace english location flash:
  paramspace english prefix en
  param aa-pilot 222
 !
!
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 100 interface GigabitEthernet0/0 overload
!

!
access-list 100 permit ip 192.168.0.0 0.0.0.255 any
!
!
!
!
dial-peer voice 222 voip
 service aa
 destination-pattern 222
 progress_ind setup enable 3
 progress_ind progress enable 8
 session target ipv4:192.168.0.1
 incoming called-number 222
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 199 voip
 destination-pattern 6........
 session protocol sipv2
 session target dns:sip.xxx.pl
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 198 voip
 translation-profile incoming IN
 session protocol sipv2
 session target dns:sip.xxx.pl
 incoming called-number .%
 dtmf-relay rtp-nte
 codec g711alaw
 no vad
!
!
sip-ua
 credentials username xxx password 7 0fewfewfewfewfew8 realm dns:sip.xxx.pl
 authentication username xxx password 7 ffewfewfewfewfew
 registrar dns:sip.xxx.pl expires 900 auth-realm xxx
 sip-server dns:sip.xxx.pl
!
!
!
telephony-service
 max-ephones 10
 max-dn 10
 ip source-address 192.168.0.1 port 2000
 cnf-file location flash:
 cnf-file perphone
 max-conferences 8 gain -6
 moh enable-g711 "en_bacd_music_on_hold.au"
 transfer-system full-consult
 transfer-pattern .T
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn  1  dual-line
 number 101
!
!
ephone-dn  2  dual-line
 number 102
!
!
ephone-dn  3  dual-line
 number 103
!
!
!
ephone  1
 mac-address C414.3C8B.A5EA
 type 6945
 button  1:3
!
!
!
ephone  3
 mac-address 0C27.24BB.E554
 type 6945
 button  1:1
!
!
!
ephone  4
 mac-address 0C27.24BA.D598
 type 6945
 button  1:2
!

Pozdrawiam,

Kamil

ODPOWIEDZ