ASR1001 - problem z polaczeniem do MGNT-INTF

Wszystkie rozmowy związane z problemem z hardwarem, supportowanymi funkcjonalnościami, wydajnością urządzeń itp.

Moderatorzy: mikrobi, garfield, gangrena, Seba, aron

Wiadomość
Autor
len
wannabe
wannabe
Posty: 73
Rejestracja: 06 cze 2011, 10:51

ASR1001 - problem z polaczeniem do MGNT-INTF

#1

#1 Post autor: len »

Witam,

Mam problem z polaczeniem sie do portu zarzadanego,
port wstaje , moge pingowac samego siebie z komenda vrf ale po roznych konfiguracjach nie moge innego ip sprawdzic czy pinguje.

Ponizej wycinek:

Router#sh ip int brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0 10.0.0.1 YES manual up up

Router#sh vrf Mgmt-intf
Name Default RD Protocols Interfaces
Mgmt-intf <not set> ipv4,ipv6 Gi0


Wycinek konfiuguracji:

vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!

interface GigabitEthernet0
vrf forwarding Mgmt-intf
ip address 10.0.0.1 255.0.0.0
negotiation auto
!

Nie jestem pewny czy port jest uszkodzony?

Awatar użytkownika
frontier
wannabe
wannabe
Posty: 1849
Rejestracja: 16 lis 2004, 13:55
Lokalizacja: Edinburgh

Re: ASR1001 - problem z polaczeniem do MGNT-INTF

#2

#2 Post autor: frontier »

A show ip route vrf Mgmt-intf ..? No i maska /8 wydaje sie podejrzana :)
Jeden konfig wart więcej niż tysiąc słów

len
wannabe
wannabe
Posty: 73
Rejestracja: 06 cze 2011, 10:51

Re: ASR1001 - problem z polaczeniem do MGNT-INTF

#3

#3 Post autor: len »

Na ASR zmienilem ip na 192.168.0.10 255.255.255.0 oraz PC na 192.168.0.20/24

Router#sh ip route vrf Mgmt-intf

Routing Table: Mgmt-intf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is 192.168.0.20 to network 0.0.0.0

S* 0.0.0.0/0 [1/0] via 192.168.0.20
192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.0.0/24 is directly connected, GigabitEthernet0
L 192.168.0.10/32 is directly connected, GigabitEthernet0
Router#

oraz wyczyszczony konfig:
Building configuration...

Current configuration : 1359 bytes
!
! Last configuration change at 15:07:42 UTC Mon Feb 26 2018
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
!
no aaa new-model
!
!
!
!
!
!
!
!
!



!
!
!
!
!
!
!
!
!
!
subscriber templating
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
license udi pid ASR1001 sn JAE1XXXXXXX
spanning-tree extend system-id
!
!
redundancy
mode none
!
!
!
!
!
!
ip tftp source-interface GigabitEthernet0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet0/0/1
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet0/0/2
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet0/0/3
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
ip address 192.168.0.10 255.255.255.0
negotiation auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 192.168.0.20
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

Awatar użytkownika
frontier
wannabe
wannabe
Posty: 1849
Rejestracja: 16 lis 2004, 13:55
Lokalizacja: Edinburgh

Re: ASR1001 - problem z polaczeniem do MGNT-INTF

#4

#4 Post autor: frontier »

no to z routera

Kod: Zaznacz cały

ping vrf Mgmt-intf 192.168.0.20
i zaraz pózniej

Kod: Zaznacz cały

show arp vrf Mgmt-intf
z PCta

Kod: Zaznacz cały

ping 192.168.0.10
i

Kod: Zaznacz cały

arp -a

Jak interfejs podniesiony a nie ma MACa no to cos nie tego.
Jeden konfig wart więcej niż tysiąc słów

len
wannabe
wannabe
Posty: 73
Rejestracja: 06 cze 2011, 10:51

Re: ASR1001 - problem z polaczeniem do MGNT-INTF

#5

#5 Post autor: len »

Router#show arp vrf Mgmt-intf
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.0.10 - 78da.6e12.8fc0 ARPA GigabitEthernet0

Router#ping vrf Mgmt-intf 192.168.0.20
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.20, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Router#sh ip int brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0/0 unassigned YES unset administratively down down
GigabitEthernet0/0/1 unassigned YES unset administratively down down
GigabitEthernet0/0/2 unassigned YES unset administratively down down
GigabitEthernet0/0/3 unassigned YES unset administratively down down
GigabitEthernet0 192.168.0.10 YES manual up up
Router#

Na PC
No ARP Entries Found

Ping
Sent=4 i Lost=4

Awatar użytkownika
frontier
wannabe
wannabe
Posty: 1849
Rejestracja: 16 lis 2004, 13:55
Lokalizacja: Edinburgh

Re: ASR1001 - problem z polaczeniem do MGNT-INTF

#6

#6 Post autor: frontier »

Najpierw ping pózniej arp nie odwrotnie :)

A tego PCta masz bezposrednio wpietego w port?
Jeden konfig wart więcej niż tysiąc słów

len
wannabe
wannabe
Posty: 73
Rejestracja: 06 cze 2011, 10:51

Re: ASR1001 - problem z polaczeniem do MGNT-INTF

#7

#7 Post autor: len »

Bezposrednio polaczony, ping i arp w tej kolejnosci tez bez rezultatu

Awatar użytkownika
frontier
wannabe
wannabe
Posty: 1849
Rejestracja: 16 lis 2004, 13:55
Lokalizacja: Edinburgh

Re: ASR1001 - problem z polaczeniem do MGNT-INTF

#8

#8 Post autor: frontier »

No to jak dla mnie cos nie tego z tym portem zakladajac ze laptop ok i dobrze skonfigurowany.
Jeden konfig wart więcej niż tysiąc słów

len
wannabe
wannabe
Posty: 73
Rejestracja: 06 cze 2011, 10:51

Re: ASR1001 - problem z polaczeniem do MGNT-INTF

#9

#9 Post autor: len »

Jest taka mozliwosc, ze port jest walniety.
Mysle, co jeszcze moge zrobic by miec pewnosc.
IOS ma X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 15.4(3)S2 - nie widzialem jakis Bug'ow odnosnie tego portu.

len
wannabe
wannabe
Posty: 73
Rejestracja: 06 cze 2011, 10:51

Re: ASR1001 - problem z polaczeniem do MGNT-INTF

#10

#10 Post autor: len »

Mam jeszcze taki output
Router#show arp vrf Mgmt-intf
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.0.10 - 78da.6e12.8fc0 ARPA GigabitEthernet0
Internet 192.168.0.20 0 Incomplete ARPA

len
wannabe
wannabe
Posty: 73
Rejestracja: 06 cze 2011, 10:51

Re: ASR1001 - problem z polaczeniem do MGNT-INTF

#11

#11 Post autor: len »

Router#sh interfaces gigabitEthernet 0
GigabitEthernet0 is up, line protocol is up
Hardware is RP management port, address is 78da.6e12.8fc0 (bia 78da.6e12.8fc0)
Internet address is 192.168.0.10/24
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full Duplex, 1000Mbps, link type is auto, media type is RJ45
output flow-control is unsupported, input flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 00:00:28, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
71 packets output, 4358 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
2 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
Router#

oraz


Router#show arp vrf Mgmt-intf detail
ARP entry for 192.168.0.10, link type IP.
Interface, via GigabitEthernet0, last updated 3 minutes ago.
Encap type is ARPA, hardware address is 78da.6e12.8fc0, 6 bytes long.
ARP subblocks:
* Interface ARP Subblock
ARP entry for 192.168.0.20, link type IP.
Incomplete, via GigabitEthernet0, last updated 0 minute ago.
Encap type is ARPA, hardware address is 0000.0000.0000, 0 bytes long.
ARP subblocks:
* Dynamic ARP Subblock
Entry is incomplete.

Router#

martino76
CCIE
CCIE
Posty: 860
Rejestracja: 17 gru 2010, 15:23
Lokalizacja: Barczewo

Re: ASR1001 - problem z polaczeniem do MGNT-INTF

#12

#12 Post autor: martino76 »

Mialem podobna sytuacje i Cisco wskazalo na tego buga https://bst.cloudapps.cisco.com/bugsear ... ng_site=ss u mnie faktycznie kolejka na interfejsie byla pelna u Ciebie widze, ze jest ok.

Nie mowie, ze to samo jest w twojej sytuacji, ale widze bardzo podobne zachowanie i brak ARPa

Pozdro,

len
wannabe
wannabe
Posty: 73
Rejestracja: 06 cze 2011, 10:51

Re: ASR1001 - problem z polaczeniem do MGNT-INTF

#13

#13 Post autor: len »

Czesc,

Sprawdzilem jeszcze wieczorem na innym ASR1001 i tam nie bylo problemu, wiec definitywnie port jest walniety.

Dzieki za pomoc i Pozdr!

ODPOWIEDZ