Juniper-Huawei MPLS TE-RSVP brak komunikacji pakietow Hello

JunOS / Juniper / Netscreen

Moderatorzy: mikrobi, aron, garfield, gangrena, Seba

Wiadomość
Autor
tirou
fresh
fresh
Posty: 7
Rejestracja: 26 lis 2018, 09:11

Juniper-Huawei MPLS TE-RSVP brak komunikacji pakietow Hello

#1

#1 Post autor: tirou » 30 lis 2018, 04:42

Witam, mam taki problem że ustawiam w sieci MPLS-TE RSVP-TE pomiędzy urządzeniami Huawei S6750/s5750 <-->Juniper MX104 <--> Huawei S6750/s5750. Jeżeli usune junipera ze ścieżki to przykładowy (ponizej konfiguracja) tunel wstaje bez problemu. Problem tylko na styku Huawei - Juniper.

Niestety urządzenia nie wymieniają między sobą pakietów Hello. Występują błędy PathErr to client Dotychczasowo posiadalem wiele tuneli l2vpn na MPLS LDP i wszystko gra - przy probie wlaczenia RSVP występuje ten problem. Mam Czy macie pomysł? Z góry dziękuje za pomoc!

Konfiguracja i statystyki (ipki zmienione - wszystko na publicznych):
juniper1# run show rsvp neighbor
RSVP neighbor: 6 learned
Address Idle Up/Dn LastChange HelloInt HelloTx/Rx MsgRcvd
185.100.100.100 1:13:10 0/0 1:13:06 9 488/0 0
185.100.100.103 1:13:10 0/0 1:13:06 9 488/0 0
193.145.167.8 1:13:10 0/0 1:13:06 9 488/0 0
PacketType Total Last 5 seconds
Sent Received Sent Received
Path 0 0 0 0
PathErr 0 0 0 0
PathTear 0 0 0 0
Resv 0 0 0 0
ResvErr 0 0 0 0
ResvTear 0 0 0 0
ResvConf 0 0 0 0
Bundle 0 0 0 0
Hello 3087 0 0 0
Ack 0 0 0 0
Srefresh 0 0 0 0
Notify 0 0 0 0
Unknown 0 0 0 0
EndtoEnd RSVP 0 0 0 0
Backup Path 0 0 0 0
Backup Tear 0 0 0 0
Cnd PathTear 0 0 0 0
Rmt PathTear 0 0 0 0
Rmt Backup 0 0 0 0

Errors Total Last 5 seconds
Rcv pkt bad length 0 0
Rcv pkt unknown type 0 0
Rcv pkt bad version 0 0
Rcv pkt auth fail 0 0
Rcv pkt bad checksum 0 0
Rcv pkt bad format 0 0
Message out-of-order 0 0
Rcv pkt disabled interface 0 0
Memory allocation fail 0 0
ID allocation failed 0 0
No path information 0 0
Resv style conflict 0 0
Port conflict 0 0
Resv no interface 0 0
PathErr to client 656 1
ResvErr to client 0 0
Path timeout 0 0
Resv timeout 0 0
Unknown ack msg 0 0
Recv nack 0 0
Recv duplicated msg-id 0 0
No TE-link to recv Hop 0 0
Transmit buffer full 0 0
Transmit failure 0 0
PLR backup Path tx failure 0 0
Receive failure 0 0
P2MP RESV discarded by app 0 0
Rate limit 0 0
Err msg loop detected 0 0
MP Path LP-avail rcved 0 0
MP Path NP-avail rcved 0 0
PLR bk RSB life ext 0 0
MP bk PSB life ext 0 0
RSB life ext for nh FRR 0 0
MP pri PSB life ext LP 0 0
Rcvd state rejected 0 0
No matching senders 0 0
Del from client 0 0
Konfiguracja JUNIPER:
juniper1# show protocols ospf
traffic-engineering;
export ospf-default;
import reject-default-route;
reference-bandwidth 100g;
area 0.0.0.0 {
interface lo0.0 {
passive;
}
interface xe-1/0/0.500;
interface lt-2/0/0.1;
interface xe-0/1/0.520 {
metric 30;
}
interface ae0.510;
interface lt-1/0/0.0;
interface xe-0/0/0.580;
}
juniper1# show protocols rsvp
interface ae0.510;
interface xe-0/0/0.580;
interface xe-0/1/0.520;
set interfaces xe-0/1/0 flexible-vlan-tagging
set interfaces xe-0/1/0 mtu 9000
set interfaces xe-0/1/0 encapsulation flexible-ethernet-services
set interfaces xe-0/1/0 unit 520 vlan-id 520
set interfaces xe-0/1/0 unit 520 family inet mtu 1500
set interfaces xe-0/1/0 unit 520 family inet address 143.75.79.109/30
set interfaces xe-0/1/0 unit 520 family inet6 mtu 1500
set interfaces xe-0/1/0 unit 520 family inet6 address 2a04:7c0a:18:6::1/126
set interfaces xe-0/1/0 unit 520 family mpls mtu 1600

Konfiguracja HUAWEI:
mpls lsr-id 1.1.1.1
mpls
mpls te
mpls te auto-frr
mpls rsvp-te
mpls rsvp-te srefresh
mpls te cspf
interface Vlanif100
description Linkk-do-RT02
ip address 10.1.2.1 255.255.255.252
mpls
mpls mtu 9000
mpls te
mpls rsvp-te
mpls ldp
interface Tunnel300
ip address unnumbered interface LoopBack0
tunnel-protocol mpls te
destination 4.4.4.4
mpls te tunnel-id 300
mpls te record-route label
mpls te fast-reroute
mpls te reserved-for-binding
mpls te commit
ospf 1
silent-interface LoopBack0
opaque-capability enable
area 0.0.0.0
network 1.1.1.1 0.0.0.0
network 10.1.2.0 0.0.0.3
network 10.1.3.0 0.0.0.3
network 10.1.4.0 0.0.0.3
mpls-te enable
#

geminiuss
member
member
Posty: 47
Rejestracja: 16 lut 2008, 00:38

Re: Juniper-Huawei MPLS TE-RSVP brak komunikacji pakietow Hello

#2

#2 Post autor: geminiuss » 30 lis 2018, 11:26

Czesc,

Ja mialem sporo dziwnych sytuacji ze cos mi nie dzialalo miedzy Juniperem i Huawei. Na google ciezko z informacjami. Ja bym proponowal od razu uderzac do TACa od Huwaei.

tirou
fresh
fresh
Posty: 7
Rejestracja: 26 lis 2018, 09:11

Re: Juniper-Huawei MPLS TE-RSVP brak komunikacji pakietow Hello

#3

#3 Post autor: tirou » 30 lis 2018, 15:52

bardzo ciężko o jakis podobny problem w google. Zastanawiam się czy to HUAWEI nie wysyla czy Juniper nie odbiera

tirou
fresh
fresh
Posty: 7
Rejestracja: 26 lis 2018, 09:11

Re: Juniper-Huawei MPLS TE-RSVP brak komunikacji pakietow Hello

#4

#4 Post autor: tirou » 03 gru 2018, 17:16

Witam, rozwiązałem problem braku pakietów Hello od strony Huawei (trzeba je jawnie uruchomić typu: MPLS RSVP-TE HELLO.

Jednak mam ostatni problem taki, że mimo poprawnie zestawianych sesji RSVP HUAWEI <-> Juniper (tunel-interface wstaje) to nie jestem w stanie uruchomić Junipera w trybie tranzytowym, tj nie mogę zmusić Junipera aby dalej tworzył tunele HUAWEI ---> JUNIPER ---> HUAWEI ??

Czego mogłem nie uruchomić na Juniperze? (bo to tu zdaje mi się, że występuje problem z "przekazywaniem" i tworzeniem LSP, gdzie Juniper byłby na ścieżce czy to EXPLICIT-PATH czy to poprzez Auto-FRR

tirou
fresh
fresh
Posty: 7
Rejestracja: 26 lis 2018, 09:11

Re: Juniper-Huawei MPLS TE-RSVP brak komunikacji pakietow Hello

#5

#5 Post autor: tirou » 05 gru 2018, 21:54

Znalazłem odpowiedz: Brakowało na Huawei jawnego włączenia mpls rsvp-te hello enable

Awatar użytkownika
konradrz
CCIE
CCIE
Posty: 341
Rejestracja: 23 sty 2008, 14:21
Lokalizacja: Singapore, SG
Kontakt:

Re: Juniper-Huawei MPLS TE-RSVP brak komunikacji pakietow Hello

#6

#6 Post autor: konradrz » 06 gru 2018, 12:41

Cytując dokumentację: "Note You can configure family mpls on either individual interfaces or aggregated Ethernet interfaces. You cannot configure it on tagged VLAN interfaces."
(choć niby wtedy nic nie powinno działać, a nie tylko tranzyt?)

tirou
fresh
fresh
Posty: 7
Rejestracja: 26 lis 2018, 09:11

Re: Juniper-Huawei MPLS TE-RSVP brak komunikacji pakietow Hello

#7

#7 Post autor: tirou » 10 gru 2018, 10:32

To mamy problem - połączeniówki pomiędzy urządzeniami w sieci mam na vlanach i nie mogę ich odtagować.

Zgadza się, wszystko działa poza tranzytem na Juniperze. Założyłem osobny WĄTEK z tym problemem, gdyż ten dotyczył dogadywania się urządzeń - tutaj rozwiązaniem było jawne włączenie hello na Huaweiu.

Awatar użytkownika
konradrz
CCIE
CCIE
Posty: 341
Rejestracja: 23 sty 2008, 14:21
Lokalizacja: Singapore, SG
Kontakt:

Re: Juniper-Huawei MPLS TE-RSVP brak komunikacji pakietow Hello

#8

#8 Post autor: konradrz » 10 gru 2018, 13:54

No właśnie dokumentacja jest dla tranzytowych pudełek (P). I mówi wyraźnie, że nie możesz używać VLAN taggingu, dla QFX (poprzedni link) i EX (ten link), dla MX nie potrafię znaleźć - ale czemu niby miałoby być inne?
Ja rozumiem, że zrobiłeś nowy wątek - ale tam nie dałeś konfiguracji, w tym wątku dopiero widać, że tagujesz -- stąd w tym odpowiedziałem.
Spróbuj odtagować, i zobacz czy zadziała.

ODPOWIEDZ