JuniperMX - brak tranzytu LSP dla RSVP

JunOS / Juniper / Netscreen

Moderatorzy: mikrobi, aron, garfield, gangrena, Seba

Wiadomość
Autor
tirou
fresh
fresh
Posty: 7
Rejestracja: 26 lis 2018, 09:11

JuniperMX - brak tranzytu LSP dla RSVP

#1

#1 Post autor: tirou » 05 gru 2018, 21:29

Witam,
mam problem z uruchomieniem tranzytu LSP dla protokołu RSVP na Juniperze.


Chce uruchomić tunel RSVP na trasie Huawei1 --> Huawei2 --> Juniper --> Huawei3. Tunel się nie zestawia, gdyż Junik blokuje utworzenie LSP do Huaweia bezpośrednio za nim.

Nie ma problemu gdy ustanawiam tunel Huawei1 --> Huawei2 lub Huawei1 --> Juniper. Juniper MX104 nie ma problemu z bycia w roli Ingress lub Egress - jedyny problem jest w tranzycie !

Juniper nie ma żadnych wpisów w tablicy mpls.0 (która służy jako tablica tranzytu) odnośnie RSVP (ścieżki LDP LSP oczywiście działają bezbłędnie).

O czym zapomniałem?


Co zrobiłem do tej pory:

1. Uruchomiłem family mpls na interfejsach połączeniówek z innymi Huaweiami
2. Dodałem powyższe interfejsy do protocol RSVP
3. Dodałem również te interfejsy do protocol mpls. Dodatkowo tutaj utworzyłem kilka testowych tuneli ( Jako Ingress oczywiście nie ma problemu- LSP sie zestawia)
4. Uruchomilem traffic-engineering, aby móc w przyszłości uzywać fast-reroute'a.


Konfiguracja oraz co zweryfikowałem poniżej:

Kod: Zaznacz cały

user-admin@rt01-jn-01# show protocols rsvp 
traceoptions {
    file rsvp-log;
}
interface xe-0/2/0.580;
interface xe-1/1/0.500;
interface ae1.530;
interface lo0.0;

Kod: Zaznacz cały

user-admin@rt01-jn-01# show protocols mpls 
ipv6-tunneling;
label-switched-path to-rt02-hw-01 {
    from IP1;
    to IP2;
    no-cspf;
}
label-switched-path to-rt02-hw-02 {
    from IP3;
    to IP4;
}
interface xe-0/2/0.580;
interface xe-1/1/0.500;
interface ae1.530;
interface lo0.0;
Co zweryfikowałem:

1. Sesje RSVP są podniesione UP - gdy Juniper działa jako Ingress.
2. Sąsiedztwo z Huaweiami jest ustanowione - Tutaj pytanie: sąsiedztwo ustanowiło mi się jedynie na adresach połączeniówek ( z loopbackami sąsiadów jest stan IDLE) - wydaje mi się że jest to prawidłowe zachowanie, ponieważ na połączeniówkach routery dogadują się między sobą, czyż nie tak?

Kod: Zaznacz cały

RSVP neighbor: 6 learned
Address                       Idle    Up/Dn LastChange HelloInt HelloTx/Rx MsgRcvd
Loopback-Neighbor1 1:07:38  0/0  5d 8:33:26        9 51423/0    0
Loopback-Neighbor2 1:07:38  0/0  5d 8:33:26        9 51423/0    0
Loopback-Neighbor3 1:07:38  0/0  5d 8:33:26        9 51423/0    0
IntAddr-Neighbor1     0  1/0  4d 20:03:10        9 144151/139146 21182
IntAddr-Neighbor2     0  1/0  4d 19:56:25        9 144083/139033 20998
IntAddr-Neighbor3     0  1/0  4d 19:59:07        9 144140/139108 10631

Gdzie popełniam błąd? Czemu Juniper nie chce działać jako TRANZYT?

Awatar użytkownika
konradrz
CCIE
CCIE
Posty: 338
Rejestracja: 23 sty 2008, 14:21
Lokalizacja: Singapore, SG
Kontakt:

Re: JuniperMX - brak tranzytu LSP dla RSVP

#2

#2 Post autor: konradrz » 10 gru 2018, 15:58

Aby zachować czystość forum :) (część dyskusji była tu, tam widać było konfigurację Junipera z tagowaniem VLANów)
No właśnie dokumentacja jest dla tranzytowych pudełek (P). I mówi wyraźnie, że nie możesz używać VLAN taggingu, dla QFX (poprzedni link) i EX (ten link), dla MX nie potrafię znaleźć - ale czemu niby miałoby być inne?
Spróbuj odtagować, i zobacz czy zadziała.

ODPOWIEDZ